• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 Help! Certain links open up a google search for Javascript:void(0)

Stuart Wright

Well-known member
#1
Started happening today and it's happening for everyone irrespective of browser.
For example, start a new conversation and click the smilies button.
Bang. Javascript void google search opens in the same browser window.
Obviously AVForums is fairly broken right now.
Can anyone help please?
 

Chris D

XenForo developer
Staff member
#5
How long has the problem been occurring? Have you made any recent changes? Installed or updated any recent add-ons?
 

Stuart Wright

Well-known member
#6
The first report from members is at 4:16pm from what I can see.
https://www.avforums.com/threads/javascript-void-null.1957654/
I edited an unused static page to repurpose it and make it available to certain usergroups
https://www.avforums.com/pages/advertisers-code-of-conduct/
and I moved several thousands threads from quiet forums into parent ones and then moved the empty forums out of the way.
That's it for me.
John Warwick did some stuff editorial related, but I don't know what and he's on Hong Kong time, so unavailable right now.
He said he was doing an update from our Youtube channel to populate the database with out-of-date data.
He may have been working on the SHOW MORE button in editorial pages (like the home page) which is buggy. That's JS related.

The first thing I noticed was at 17:33 when I saw that the links to the videos in our MEDIA widget on the home page were behaving weirdly. I fixed those by putting noskim round the links.

It's almost like the server is making links with JS actions open the URL in addition to firing the desired JS actions.
 
Last edited:

Chris D

XenForo developer
Staff member
#12
I was in the process of disabling/enabling template modifications when it happened. Of course these aren't disabled when listeners are disabled so that means it could still be an add-on.

So I'm going to disable all add-ons properly and have another look.
 

Chris D

XenForo developer
Staff member
#13
What are the chances. Started disabling them all in alphabetical order and the culprit was in the A's!

Just testing it with all others enabled now...
 

Chris D

XenForo developer
Staff member
#15
It's Skimlinks.

Not the add-on, but Skimlinks itself. If you take the code out and just put the recommended code from Skimlinks into a template directly, it still breaks everything.

So, one to have a word with them about.
 

Stuart Wright

Well-known member
#16
So they have changed their code today, obviously.
I'm going to have a serious word with them tomorrow.
Thank you so much, Chris.

I want to also thank Tim from Nimbus who worked this evening to check that there was no server issue. There was not.
 
Last edited: