• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
[HA] Featured Members (+ Verified Badge)

[HA] Featured Members (+ Verified Badge) 1.5.0

No permission to download

Dadparvar

Well-known member
#1
Dadparvar submitted a new resource:

[HA] Featured Members (+ Verified Badge) - Feature members and give them verified badge

Hi,

Have you ever seen in facebook or twitter or instagram some accounts have verified badge? This add-on let you have the same functionality in your xenforo + a few more features.

Features:
  • Ability to set any user as Featured Member
  • Featured Members will have a verified badge next to their username (everywhere that xf supports rich username)
  • When you hover the mouse over the badge, it will show a tooltip explaining the badge.
  • There is a Widget Renderer for Widget...
Read more about this resource...
 

Veer

Well-known member
#4
Good idea. I'd also like to implement just Verified badge next to User names same as on Twitter and Facebook. I'm not sure what kind of verification twitter & fb does to display verified badge, but there should be some sort of verification or criteria other than email address.
 
Last edited:

Dadparvar

Well-known member
#5

Goodfella

Well-known member
#7
I get the following error
Code:
Mysqli prepare error: Unknown column 'is_verified' in 'field list'
Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 632
Zend_Db_Adapter_Abstract->update() in Dadparvar/featuredmembers/XenForo/ControllerAdmin/User.php at line 22
Dadparvar_featuredmembers_XenForo_ControllerAdmin_User->actionSave() in XenForo/FrontController.php at line 351
XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
XenForo_FrontController->run() in /home/medrookie/public_html/community/admin.php at line 13
 
Last edited:

Dadparvar

Well-known member
#9
You are adding addon specific fields to core XF tables (xf_user table in this case) and not prefixing those addon specific fields with your addon_id. You need to prefix them something like this: eg dad_fm_is_featured and dad_fm_is_verified
thanks Bob for the guide. I'll soon update it with appropriate changes. (to be honest, I really didn't know that till that time that, that would cause this. Thanks)
 

Dadparvar

Well-known member
#12
Does this work only for the default theme? Not displaying in customized themes.
No addon is promised to work on any custom style, but, this is installed on multiple site and almost all of them were custom style. 2 of em were mine. Soon it will also be installed on xen-on which is using custom style and I'm sure it will perfectly work. As I'm using a stabdard style from a professional designer.

With that said, see what is wrong with your site. And if needed, me and/or others can help you here or on xen-pro if needed.
 

Dadparvar

Well-known member
#15
Its not weird that UI.X has problem with an add-on.
If you want, you can contact me privately and I take a quick look to see what is going on there.
 

Wesker

Well-known member
#16
Its not weird that UI.X has problem with an add-on.
If you want, you can contact me privately and I take a quick look to see what is going on there.
I think I fixed it. Now the issue is when I try to enable it I get this error:

The following error occurred:
Mysqli prepare error: Unknown column 'dad_fm_is_verified' in 'field list'
  1. Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
  2. Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
  3. Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
  4. Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 632
  5. Zend_Db_Adapter_Abstract->update() in Dadparvar/featuredmembers/XenForo/ControllerAdmin/User.php at line 22
  6. Dadparvar_featuredmembers_XenForo_ControllerAdmin_User->actionSave() in XenForo/FrontController.php at line 351
  7. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
  8. XenForo_FrontController->run() in /secondary/www/website/public_html/admin.php at line 13
Now I need your assistance.
 

Dadparvar

Well-known member
#17
Now I need your assistance.
You sure you used latest version's files and xml?

Lets do this: rmove it completely. Upload the files again. Import the xml to install it from scratch. Somehow im sure this will fix things in your case, if not, then drop me a pm and I'll help get it to work as it must :)