• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Partial fix Google search console: sitemap pending due to query string param

Mike

XenForo developer
Staff member
#81
I don't really think there's much we can do about that. Clearly if Google is picking up the values, then it is just its prerogative as to what it indexes. It may even just be a quirk of the webmaster tools interface (which I believe we have seen before). Google has always said the sitemap is just one signal it uses and it will still crawl your site naturally, so it's possible it's just not allocating things to the "new" sitemap that it may have seen "naturally".

At the very least, I think we can call this at least a partial fix for the pending issue and can explore any further changes separately.
 

JamesBrown

Well-known member
#90
I'm attaching a unified diff for XF1 if you'd like to apply the equivalent fix there to confirm that this resolves the problem for other people.
This looks like its the fix I need but I have no idea what a unified diff is or what to do with it. Could I get an idiots guide please, cheers.
 

JamesBrown

Well-known member
#95
Thanks thats seems to have fixed it thanks. (y)

QQ . via the auto-generated sitemap, xF is submitting about 120k of URLs.. However the forum has 156k threads and 2.5m posts I'd have thought there would be more URLs submitted, is something wrong?
 

Kevin

Well-known member
#96
Thanks thats seems to have fixed it thanks. (y)

QQ . via the auto-generated sitemap, xF is submitting about 120k of URLs.. However the forum has 156k threads and 2.5m posts I'd have thought there would be more URLs submitted, is something wrong?
Are any of your threads in forums that aren't viewable by guests? The sitemap will only generate entries for content that is guest viewable.
 
#98
Hello ,

I have followed the instruction that are in .diff file and i try to resubmit the the sitemap.php in google webmaster tools but with no success.
Can anyone help us by uploading the fixed files that are working ok and the exactly path where to put them. Here are the files that are not working sitemap.php is in the root folder and 2 other files are in library/xenforo . Thanks!
 

Chris D

XenForo developer
Staff member
#99
Code is really only supposed to be available to licensed customers so it's best to avoid posting entire files, where possible.

At this stage, if you can't work from the diff that has been provided, the suggestion is to just wait until the next release which should be within the coming weeks.

As it stands right now, although it may be affecting the visibility of your sitemaps, it does not affect Google's visibility of your site and for the most part they will continue to organically find the pages to index without the sitemap.