1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Google Login and Recaptcha Not Working

Discussion in 'Troubleshooting and Problems' started by bloop, Aug 3, 2015.

Tags:
  1. bloop

    bloop Member

    Hope someone can help.

    When trying to log in with Google this error appears

    Code:
    Unable to Connect to ssl://accounts.google.com:443. Error #110: Connection timed out
    
    Zend_Http_Client_Adapter_Socket->connect() in Zend/Http/Client.php at line 973
    Zend_Http_Client->request() in XenForo/ControllerPublic/Register.php at line 1030
    XenForo_ControllerPublic_Register->actionGoogle() in XenForo/FrontController.php at line 347
    XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    XenForo_FrontController->run() in /***/nginx/mydomain.com/public/index.php at line 13
    Also when new users sign up I see this error in admin panel

    Code:
    Zend_Http_Client_Adapter_Exception: ReCAPTCHA (No CAPTCHA) connection error: Unable to Connect to ssl://www.google.com:443. Error #110: Connection timed out - library/Zend/Http/Client/Adapter/Socket.php:235
    
    #0 mydomain.com/public/library/Zend/Http/Client.php(973): Zend_Http_Client_Adapter_Socket->connect('www.google.com', 443, true)
    #1 mydomain.com/public/library/XenForo/Captcha/NoCaptcha.php(76): Zend_Http_Client->request()
    #2 mydomain.com/public/library/XenForo/Captcha/Abstract.php(129): XenForo_Captcha_NoCaptcha->isValid(Array)
    #3 mydomain.com/public/library/XenForo/ControllerPublic/Register.php(355): XenForo_Captcha_Abstract::validateDefault(Object(XenForo_Input))
    #4 mydomain.com/public/library/XenForo/FrontController.php(347): XenForo_ControllerPublic_Register->actionRegister()
    #5 mydomain.com/public/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #6 mydomain.com/public/index.php(13): XenForo_FrontController->run()
    #7 {main}
    
    I checked port 443 and it is open in csf.

    I tried running # telnet google.com 443

    Output is:
    Code:
    Trying 2607:f8b0:4006:80d::1004...
    telnet: connect to address 2607:f8b0:4006:80d::1004: Connection timed out
    Trying 173.194.123.105...
    Connected to google.com.
    Escape character is '^]'.
    Connection closed by foreign host.
    Is this because of IPv6? Thanks.
     
  2. Mike

    Mike XenForo Developer Staff Member

    It looks likely. It appears that you have IPv6 configured, but perhaps blocked. Telnet appears to fallback to IPv4, but other systems likely won't, including PHP. You may need to look at disabling IPv6, preferring IPv4 DNS results, or allowing some outgoing connections on IPv6.
     
  3. bloop

    bloop Member

    Ipv6 was disabled. but I'm still getting this error. The odd thing is I started getting this error out of no where a few days ago on my old server. I migrated yesterday to a new server and I thought the error would go away but it is still occurring.

    Not sure what else it can be, any advice/help is much appreciated, thanks!
     
  4. Minecraftly

    Minecraftly Member

    I started having this problem when moving my forum to Google App Engine
     
  5. MetalRush

    MetalRush Member

    We have this problem as well.
    Created a Google key.
    Checked: works.
    Day after: problems.
    New key generated.
    Tested: works.
    Day after: problems.
    Huh...?

    Code:
    Zend_Http_Client_Adapter_Exception: ReCAPTCHA (No CAPTCHA) connection error: Unable to Connect to ssl://www.google.com:443. Error #0: - library/Zend/Http/Client/Adapter/Socket.php:235
    Gegenereerd Door: Onbekend Account, zondag om 18:31
    
    Code:
    #0 /home/vhosts/opelomegaportal.nl/httpdocs/forum/library/Zend/Http/Client.php(973): Zend_Http_Client_Adapter_Socket->connect('www.google.com', 443, true)
    #1 /home/vhosts/opelomegaportal.nl/httpdocs/forum/library/XenForo/Captcha/NoCaptcha.php(76): Zend_Http_Client->request()
    #2 /home/vhosts/opelomegaportal.nl/httpdocs/forum/library/XenForo/Captcha/Abstract.php(129): XenForo_Captcha_NoCaptcha->isValid(Array)
    #3 /home/vhosts/opelomegaportal.nl/httpdocs/forum/library/XenForo/ControllerPublic/Register.php(355): XenForo_Captcha_Abstract::validateDefault(Object(XenForo_Input))
    #4 /home/vhosts/opelomegaportal.nl/httpdocs/forum/library/XenForo/FrontController.php(351): XenForo_ControllerPublic_Register->actionRegister()
    #5 /home/vhosts/opelomegaportal.nl/httpdocs/forum/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #6 /home/vhosts/opelomegaportal.nl/httpdocs/forum/index.php(13): XenForo_FrontController->run()
    #7 {main}
    
    [EDIT]
    I just created a new account myself.
    Although it also generated an error, the request passed and a new account could be created.
    A thing which popped in mind: could it have something to do with either the conversion from PHPBB (which we came from) of with two custom fields we added (in PHPBB) in the profile form (those fields are mandatory btw)?
    [/EDIT]
     
    Last edited: Feb 15, 2016
  6. Mike

    Mike XenForo Developer Staff Member

    If we get an error when validating a captcha, we log it but proceed as if it were completed correctly.

    In terms of your error, that's a connection/SSL error with Google. It might indicate that your PHP doesn't have a trusted certificate store setup properly, though that shouldn't change without you upgrading PHP (to 5.6 or newer). It could just be a temporary network issue.

    If it is down to SSL certificates, conceptually this is covered here: https://akrabat.com/ssl-certificate-verification-on-php-5-6/ However, the specifics might vary from server to server (as to where the file would be, etc).
     
  7. MetalRush

    MetalRush Member

    How do I setup a trusted certificate strore?
    Isn't this something my hosting party is responsible for?
    We do have SSL on our domain.
    How is PHP involved in this?
     
  8. Mike

    Mike XenForo Developer Staff Member

    Is this a consistent problem? As in, is it still happening today and has it been happening each time?

    Is this a dedicated server/VPS or shared hosting? If the latter, any SSL stuff (in terms of outgoing connections) would certainly be your host's responsibility. Something must have changed if it worked without issue before though.
     
  9. MetalRush

    MetalRush Member

    The problem is consistent and still occurs today.
    I cannot tell if all registrations are creating an error like this, but I expect they do.
    Our server is a shared server. I am suspecting they will not change anything. Imagick is not supported by them either.. :(
     
  10. bloop

    bloop Member

  11. MetalRush

    MetalRush Member

    Thanks for your idea, Bloop.
    I will surely check with my provider and see if there is a problem on their side.
    Will report back.
     

Share This Page