1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Google indexing threads as /threads/123 instead of /threads/thread-name.123

Discussion in 'Troubleshooting and Problems' started by imthebest, Oct 20, 2014.

  1. imthebest

    imthebest Formerly Super120

    What title says.
     
  2. Chris D

    Chris D XenForo Developer Staff Member

    Need more detail.

    Are you using the sitemap generation in XF? Do you have content titles enabled in URLs? Are all of your URLs indexed like this or just some? Do you have an example of URLs which are being indexed like this?
     
  3. imthebest

    imthebest Formerly Super120

    Are you using the sitemap generation in XF?
    Yes.

    Do you have content titles enabled in URLs?
    Yes.

    Are all of your URLs indexed like this or just some?
    Some.

    I just migrated from vBulletin 3.8 and I'm using the Redirection Scripts by @Mike
     
  4. Chris D

    Chris D XenForo Developer Staff Member

    It's likely this.

    Google is following old vBulletin URLs and getting a 301 redirect from, e.g:

    showthread?t=123 => threads/123

    The redirection scripts do not query for the full thread information.

    It's worth noting, though, that this would be slightly odd behaviour on Google's part.

    Due to the URL canonicalisation the redirects should go as such:

    showthread?t=123 => threads/123 => threads/thread-name.123

    I would be expecting Google to index what it gets to after the final redirection.

    That being said, I'm pretty sure the Sitemap generation will eventually put this right, and eventually the vBulletin redirects will be less relevant as your new site gets indexed normally.
     
    imthebest likes this.
  5. shankar00009

    shankar00009 Member

Share This Page