1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Google Analytics not verifying "big" accounts

Discussion in 'Resolved Bug Reports' started by Andy Huang, Oct 5, 2010.

  1. Andy Huang

    Andy Huang Well-Known Member

    My analytics account is getting huge, and I should really make more, but in the mean time, my analytics UA code ends in double digits. The default XenForo installation checks for UA-XXXXXX-Y instead of -YY, and this causes a problem. To resolve this for the current beta build (future versions will have this sorted), you will need to modify a file.

    Open /library/XenForo/DataWriter/Helper/Option.php
    Find:
    Code:
    if ($wpId !== '' && !preg_match('/^UA-\d+-\d$/', $wpId))
    Replace with:
    Code:
    if ($wpId !== '' && !preg_match('/^UA-\d+-\d+$/', $wpId))
    Kier mentioned that he fixed it as we chatted on Skype already, so I've already appended the Fixed tag in the thread title.
     
  2. giorgino

    giorgino Well-Known Member

    really thank you! Work perfect!
     
  3. kprojects

    kprojects Well-Known Member

    Thanks!
     

Share This Page