1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Google Analytics list forum home as /index.php?forum/= , why?

Discussion in 'Off Topic' started by mrb1972, Oct 3, 2012.

  1. mrb1972

    mrb1972 Active Member

    I noticed today that google analytics lists my forum home landing page as /index.php?forum/= which when clicked on redirects to my xenporta home page

    I dont think the = should be in the url so I dont know why google is doing that

    *update its actually doing it for all url's excect the homepage *

    anyone have any ideas?
     
  2. CyclingTribe

    CyclingTribe Well-Known Member

    Have you got friendly URLs enabled in the Admin Control Panel?
     
  3. mrb1972

    mrb1972 Active Member

    no just the standard url's
     
  4. CyclingTribe

    CyclingTribe Well-Known Member

    It may help if you enable friendly URLs, but can you give me a link to your site first so I can have a quick look.
     
  5. mrb1972

    mrb1972 Active Member

    its www.manutdtalk.com and all works fine and the url's look fine, its just the way google analytics logs the url's
     
  6. CyclingTribe

    CyclingTribe Well-Known Member

    Your forum URL (http://www.manutdtalk.com/community/) is being redirected to:

    Code:
    http://www.manutdtalk.com/index.php?forum/
    
    Which is why Analytics is showing it that way; your individual forums are linked in a similar way:

    Code:
    http://www.manutdtalk.com/index.php?community/transfer-talk.3/
    
    Enabling friendly URLs will remove the index.php?/ element and normalise them to:

    Code:
    http://www.manutdtalk.com/community/
    
    ... and ...

    Code:
    http://www.manutdtalk.com/community/transfer-talk.3/
    
    However you seem to have a portal page in place and several other XF pages who's links may be impacted by enabling friendly URLs so I'd check in the add-on thread to see how others are handling it first?

    It's also not something you can reverse so needs to be properly assessed before switching (since you've already got a busy, established, link-filled site).

    Cheers,
    Shaun :D
     
  7. CyclingTribe

    CyclingTribe Well-Known Member

    The alternative, of course, is to just leave it as it is - now that you know why it's being displayed that way. (y)
     
  8. mrb1972

    mrb1972 Active Member

    im using the router changer addon thats probably why, I had a problem using friendly url's so I had to leave them off
     
  9. CyclingTribe

    CyclingTribe Well-Known Member

    Okay, dokey - well at least you know the why and wherefore now. ;)
     

Share This Page