Fixed Full Unicode support has been enabled in config.php but your database is not set to support this.


Well-known member
Affected version
v2.2.10 Patch 1
The following error message is displayed in the Admin control panel:


According to the client the message started to be displayed perhaps a couple XenForo upgrades ago, he is currently running the latest version v2.2.10 Patch 1.

The config.php file does not contain the $config['fullUnicode'] = true; line.

His tables are utf8mb3_general_ci collation, his forum is located in Greece and Greek is the primary language.
Last edited:
\XF\Db\SchemaManager::hasUnicodeMismatch understands utf8 and utf8mb4, but not utf8mb3. It doesn't know that utf8 and utf8mb3 are equivalent, so this probably constitutes a legitimate bug.

As a workaround, if you're on a version of MySQL or MariaDB that supports utf8mb4, I strongly recommend running cmd.php xf:convert-utf8mb4 to convert everything to utf8mb4. Make sure you have backups, and it's always best to test that on dev or staging site first. Edit: There are reports of this command failing with utf8mb3:

Setting Character Sets​

In MariaDB, the default character set is latin1, and the default collation is latin1_swedish_ci (however this may differ in some distros, example ubuntu). to solve this problem :​

1. Login to your ftp program with SFTP protocol.

2. in /etc/mysql/mariadb.conf.d/ Open 50-server.cnf with any editor.

3. Find Character sets, delete the 2 command lines marked in the picture just below. Save and exit.
character-set-server = utf8mb4
collation-server = utf8mb4_general_ci
4. return to the ssh screen. Run the following command line once for your changes to take effect.
systemctl restart mariadb.service

Thank you for reporting this issue, it has now been resolved. We are aiming to include any changes that have been made in a future XF release (2.2.12).

Change log:
Add support for detecting utf8mb3 and treating it the same as utf8 thus ensuring unicode mismatch detection and table conversion to utf8mb4 is working correctly.
There may be a delay before changes are rolled out to the XenForo Community.
Top Bottom