• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Full Friendly URL Support Issues

Kainzo

Active member
#1
I'm testing our full friendly URL support for a new project I'm helping with <site>. Whenever its enabled I get the below;
Not Found
The requested URL /community/conversations/popup was not found on this server.

This occurs on many different areas, as if the rewrite rules werent working.

https://gyazo.com/d2bdc5e8f59578bc3f1e53f35c64350f
I have enabled mod_rewrite
I have ensured that its installed
I have also setup the .htaccess file and restart httpd
I have Wordpress running @ site but I don't believe that will be an issue.
.htaccess in the root of XF dir > http://paste2.org/wxht3eYB
I have also ensured that AllowedRewrite is enabled.

So far I'm at a loss here and maybe I can get some help from experienced users on why this isnt working.
 
Last edited by a moderator:

Robust

Well-known member
#2
If you placed the file in your XF directory, I believe you should comment this line:
Code:
RewriteBase /community
If that doesn't work:

  • Have you contacted your host yet to make sure they aren't blocking the htaccess file or anything?
  • Have you got "AllowOverride All" in your site configuration?
  • Are you sure the web server user can read the .htaccess file? Check the file permissions.
  • Do you see any errors/warnings in your Apache server log?
 

Kainzo

Active member
#3
If you placed the file in your XF directory, I believe you should comment this line:
Code:
RewriteBase /community
If that doesn't work:

  • Have you contacted your host yet to make sure they aren't blocking the htaccess file or anything?
  • Have you got "AllowOverride All" in your site configuration?
  • Are you sure the web server user can read the .htaccess file? Check the file permissions.
  • Do you see any errors/warnings in your Apache server log?
I have tried commenting out that line for RewriteBase / community.
I am the host, I host with Digitical Ocean, we are on CentOS 7.
File permissions are "R" on all.
Checking the error log now.
 
Last edited:

TMC

Active member
#7
.htaccess in the root of XF dir > http://paste2.org/wxht3eYB
Looking at that, I noticed that you've got two RewriteBases defined
Code:
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
# If you are having problems with the rewrite rules, remove the "#" from the
# line that begins "RewriteBase" below. You will also have to change the path
# of the rewrite to reflect the path to your XenForo installation.
RewriteBase /community
If that's still the case, remve the other one (without /community) and try again. Maybe that helps.
 

Kainzo

Active member
#8
Looking at that, I noticed that you've got two RewriteBases defined
Code:
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
# If you are having problems with the rewrite rules, remove the "#" from the
# line that begins "RewriteBase" below. You will also have to change the path
# of the rewrite to reflect the path to your XenForo installation.
RewriteBase /community
If that's still the case, remve the other one (without /community) and try again. Maybe that helps.
I now only have one RewriteBase / --- i restarted httpd and it still fails on enabling the full friendly URL.

Thanks for the attempt though! :D
 

TMC

Active member
#10
I now only have one RewriteBase / --- i restarted httpd and it still fails on enabling the full friendly URL.

Thanks for the attempt though! :D
Ahh sorry I was a bit unclear with the instructions. I meant that you should keep the /community part.

So like this
Code:
# Mod_security can interfere with uploading of content such as attachments. If you
# cannot attach files, remove the "#" from the lines below.
#<IfModule mod_security.c>
# SecFilterEngine Off
# SecFilterScanPOST Off
#</IfModule>

ErrorDocument 401 default
ErrorDocument 403 default
ErrorDocument 404 default
ErrorDocument 405 default
ErrorDocument 406 default
ErrorDocument 500 default
ErrorDocument 501 default
ErrorDocument 503 default

<IfModule mod_rewrite.c>
RewriteEngine On
# If you are having problems with the rewrite rules, remove the "#" from the
# line that begins "RewriteBase" below. You will also have to change the path
# of the rewrite to reflect the path to your XenForo installation.
RewriteBase /community


# This line may be needed to enable WebDAV editing with PHP as a CGI.
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -l [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^.*$ - [NC,L]
RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
RewriteRule ^.*$ index.php [NC,L]
</IfModule>
If that doesn't work either, then I'm out of ideas.
 

Kainzo

Active member
#11
K, I tried the below and it's still having errors (Reference > http://example/community/conversations/)
Code:
#    Mod_security can interfere with uploading of content such as attachments. If you
#    cannot attach files, remove the "#" from the lines below.
#<IfModule mod_security.c>
#    SecFilterEngine Off
#    SecFilterScanPOST Off
#</IfModule>

ErrorDocument 401 default
ErrorDocument 403 default
ErrorDocument 404 default
ErrorDocument 405 default
ErrorDocument 406 default
ErrorDocument 500 default
ErrorDocument 501 default
ErrorDocument 503 default

<IfModule mod_rewrite.c>
    RewriteEngine On

    #    If you are having problems with the rewrite rules, remove the "#" from the
    #    line that begins "RewriteBase" below. You will also have to change the path
    #    of the rewrite to reflect the path to your XenForo installation.
    RewriteBase /community

    #    This line may be needed to enable WebDAV editing with PHP as a CGI.
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]
</IfModule>
 
Last edited by a moderator:

Kevin

Well-known member
#12
@Kainzo, did you ever find an answer? My server was recently updated from Centos6 to 7 and now after the upgrade 'friendly URLs' isn't working for me in just XF; they work fine in Wordpress but not XF even using the stock XF copy of htaccess.