• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

friendly url's with nginx (windows)

#1
Code:
    server {
        listen      80;
        server_name  domain.com www.domain.com;
 
        #charset koi8-r;
 
        #access_log  logs/host.access.log  main;
 
        location / {
            try_files $uri $uri/ /index.php?$uri&$args;
            limit_rate      1200k;
            autoindex  on;
            root  E:\sites\cp;
            index  index.php index.html index.htm;
        }
 
        location /internal_data/ {
                internal;
        }
        location /library/ {
                internal;
        }
       
        #error_page  404              /404.html;
 
        # redirect server error pages to the static page /50x.html
        #
        error_page  500 502 503 504  /50x.html;
        location = /50x.html {
            root  E:\sites\cp;
        }
 
        # proxy the PHP scripts to Apache listening on 127.0.0.1:80
        #
        #location ~ \.php$ {
        #    proxy_pass  http://127.0.0.1;
        #}
 
        # pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000
        #
        location ~ \.php$ {
            try_files $uri /index.php
            root          E:\sites\cp;
            fastcgi_pass  127.0.0.1:9123;
            fastcgi_index  index.php;
            fastcgi_param  SCRIPT_FILENAME $document_root$fastcgi_script_name;
            include        fastcgi_params;
        }
Xenforo is installed in the root folder " E:\sites\cp".
Result is a 404 not found.
 
#3
Your root directives might need to come first in your location blocks. Just guessing.

For reference:
http://wiki.nginx.org/NginxHttpCoreModule#root
You mean like this?
Code:
    server {
        listen      80;
        server_name  domain.com www.domain.com.com;
 
        #charset koi8-r;
 
        #access_log  logs/host.access.log  main;
 
        location / {
            root  E:\sites\cp;
            try_files $uri $uri/ /index.php?$uri&$args;
            limit_rate      1200k;
            index  index.php index.html index.htm;
        }
 
        location /internal_data/ {
            root  E:\sites\cp;
                internal;
        }
        location /library/ {
            root  E:\sites\cp;
                internal;
        }
 
        # proxy the PHP scripts to Apache listening on 127.0.0.1:80
        #
        #location ~ \.php$ {
        #    proxy_pass  http://127.0.0.1;
        #}
 
        # pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000
        #
        location ~ \.php$ {
            try_files $uri /index.php
            root          E:\sites\cp;
            fastcgi_pass  127.0.0.1:9123;
            fastcgi_index  index.php;
            fastcgi_param  SCRIPT_FILENAME $document_root$fastcgi_script_name;
            include        fastcgi_params;
        }
 
#4
You mean like this?
Code:
    server {
        listen      80;
        server_name  domain.com www.domain.com.com;
 
        #charset koi8-r;
 
        #access_log  logs/host.access.log  main;
 
        location / {
            root  E:\sites\cp;
            try_files $uri $uri/ /index.php?$uri&$args;
            limit_rate      1200k;
            index  index.php index.html index.htm;
        }
 
        location /internal_data/ {
            root  E:\sites\cp;
                internal;
        }
        location /library/ {
            root  E:\sites\cp;
                internal;
        }
 
        # proxy the PHP scripts to Apache listening on 127.0.0.1:80
        #
        #location ~ \.php$ {
        #    proxy_pass  http://127.0.0.1;
        #}
 
        # pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000
        #
        location ~ \.php$ {
            try_files $uri /index.php
            root          E:\sites\cp;
            fastcgi_pass  127.0.0.1:9123;
            fastcgi_index  index.php;
            fastcgi_param  SCRIPT_FILENAME $document_root$fastcgi_script_name;
            include        fastcgi_params;
        }
With this i get a 500 internal server error.
 
#5
Nobody?

I see this in the log, i dont think its related to the problem.

Code:
2012/12/07 19:56:16 [crit] 3280#2652: *90 CreateFile() "E:\nginx/htmlE:\sites\cp" failed (123: The filename, directory name, or volume label syntax is incorrect), client: 84.193.1.*, server: doamin.com, request: "GET /favicon.ico HTTP/1.1", host: "domain.com", referrer: "http://domain.com/"
Also this, looks weird.
Code:
2012/12/07 14:34:27 [crit] 3280#2652: *43 GetFileAttributesEx() "E:\nginx/html/http:/domain.com/index.php/index.php/index.php" failed (123: The filename, directory name, or volume label syntax is incorrect), client: 211.144.76.*, server: domain.com, request: "GET /http:/domain.com/index.php/index.php/index.php HTTP/1.0", host: "domain.com", referrer: "http://domain.com/index.php"