1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Friendly URL's problem

Discussion in 'XenForo Questions and Support' started by Bestle, Dec 24, 2012.

  1. Bestle

    Bestle Member

    Hi there

    My xenforo installation is located at /forums

    I use the following .htaccess file for friendly urls.

    #    Mod_security can interfere with uploading of content such as attachments. If you
    #    cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    #    SecFilterEngine Off
    #    SecFilterScanPOST Off
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default
    <IfModule mod_rewrite.c>
        RewriteEngine On
        #    If you are having problems with the rewrite rules, remove the "#" from the
        #    line that begins "RewriteBase" below. You will also have to change the path
        #    of the rewrite to reflect the path to your XenForo installation.
        RewriteBase /forums
        #    This line may be needed to enable WebDAV editing with PHP as a CGI.
        #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
        RewriteCond %{REQUEST_FILENAME} -f [OR]
        RewriteCond %{REQUEST_FILENAME} -l [OR]
        RewriteCond %{REQUEST_FILENAME} -d
        RewriteRule ^.*$ - [NC,L]
        RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
        RewriteRule ^.*$ index.php [NC,L]
    For some reason I am getting URL's such as http://domain.com/forums/forums/staff-applications.6/

    How do I fix this?

  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    I assume you are referring to the double "forums/forums"? One is a directory. The other is a route. It is correct.

    If you don't want the double "forums/forums" then you have two options:

    1) Change the name of the "forums" directory on your server. Then update the URL:

    Admin CP -> Home -> Options -> Basic Board Information -> Board URL

    2) Or use this addon to change the name of the "forums" route:


Share This Page