• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Not a bug Forums moved from /html/ to /html/forums?

Affected version
2.0
#1
Why was the index moved from the root /html/ to / html/forums?

I wanted the index of the forums in the html root. Now, after upgrading, the html root gives an error and the forums only show up under websitename/forums.

Not happy at all the developers decided to change my forum path.
 

Brogan

XenForo moderator
Staff member
#2
Nothing has changed.

The forums path has always been /forums, it is just masked when the forum index is set as the index page route.

Change the index page route to forums/ and the forum index will appear at the root directory where XF is installed.

This behaviour is identical to how it was in 1.x.
 
#3
Change the index page route to forums/ and the forum index will appear at the root directory where XF is installed.
How do I do that? Is there a setting in the admin panel?

I looked using FTP and there is no /forum/ folder under html/


This behaviour is identical to how it was in 1.x.
If it was "identical", I would not be getting error messages.
 

Attachments

#4
Still waiting on an answer.

After the 2.0 update, why are my forums now under /forums instead of the html root?

Do I need to open a trouble ticket? I want the forum under the html root and not /forums/
 

Mike

XenForo developer
Staff member
#5
The option is called "index page route"; you can find it with the ACP search. You have likely changed that to point to a page that relates to an add-on. That add-on is now disabled and thus returning a 404 would be expected.

You'd either need to upgrade/install an add-on that covers it or change it to "forums/".
 
#6
The option is called "index page route"; you can find it with the ACP search. You have likely changed that to point to a page that relates to an add-on. That add-on is now disabled and thus returning a 404 would be expected.

You'd either need to upgrade/install an add-on that covers it or change it to "forums/".
This is a brand new forum with no add-ons.

Index page route is /

Screenshot

comic-index-route.jpg
 

Mike

XenForo developer
Staff member
#7
The default value of that (in XF1 and XF2) is "forums/", so it looks like it has been changed to a value that doesn't generally make sense (and thus wouldn't have defined behavior). You should change it to the value I recommended.
 

~kevin~

New member
#8
The default value of that (in XF1 and XF2) is "forums/", so it looks like it has been changed to a value that doesn't generally make sense (and thus wouldn't have defined behavior). You should change it to the value I recommended.
I installed the forums to the html root / and that is where I want them to stay.

How do I get rid of /forums and get the forum index back the html root?

I do not care what the default value is. The forums were installed where I wanted them, and my setup was changed with the 2.0 update.
 

Andrej

Well-known member
#9
How do I get rid of /forums and get the forum index back the html root?
You have been already told three times on how to do that, but for some arbitrary reason you still ignore it.

Change the index page route to forums/ and the forum index will appear at the root directory where XF is installed.
... or change it to "forums/".
You should change it to the value I recommended.
 
Last edited:
#10
You have been already told three times on how to do that, but for some arbitrary reason you still ignore it.
Thank you. I did not understand the setting they suggested. changing the index page route from

/

to

forums/

Fixed the problem.

Thank you again.