XF 2.2 Moved from a VPS to shared hosting and the server errors will not stop.

Erin Nicole

Member
I keep getting different ones. I'm ignoring any having to do with addons because those probably just need to be re-downloaded and uploaded. I'm just focusing on core XF as I have already re-downloaded BOTH the upgrade package AND the full XF zip and re-uploaded those.

I keep getting template errors like this one:
  • ErrorException: Template error: [E_USER_WARNING] Template public:thuix_account_preferences_style_options is unknown
  • src/XF/Template/Templater.php:689
  • Generated by: Nomad
  • Jan 22, 2022 at 11:14 PM
Stack trace:
Code:
#0 [internal function]: XF\Template\Templater->handleTemplateError(512, '[E_USER_WARNING...', '/home/u11027819...', 689, Array)
#1 src/XF/Template/Templater.php(689): trigger_error('Template public...', 512)
#2 src/XF/Template/Templater.php(1618): XF\Template\Templater->getTemplateData('public', 'thuix_account_p...')
#3 src/XF/Template/Templater.php(1680): XF\Template\Templater->renderTemplate('thuix_account_p...', Array)
#4 internal_data/code_cache/templates/l1/s10/public/account_preferences.php(214): XF\Template\Templater->includeTemplate('public:thuix_ac...', Array)
#5 src/XF/Template/Templater.php(1651): XF\Template\Templater->{closure}(Object(SV\StandardLib\XF\Template\Templater), Array, NULL)
#6 src/XF/Template/Template.php(24): XF\Template\Templater->renderTemplate('account_prefere...', Array)
#7 src/XF/Mvc/Renderer/Html.php(50): XF\Template\Template->render()
#8 src/XF/Mvc/Dispatcher.php(460): XF\Mvc\Renderer\Html->renderView('XF:Account\\Pref...', 'public:account_...', Array)
#9 src/XF/Mvc/Dispatcher.php(442): XF\Mvc\Dispatcher->renderView(Object(XF\Mvc\Renderer\Html), Object(XF\Mvc\Reply\View))
#10 src/XF/Mvc/Dispatcher.php(402): XF\Mvc\Dispatcher->renderReply(Object(XF\Mvc\Renderer\Html), Object(XF\Mvc\Reply\View))
#11 src/XF/Mvc/Dispatcher.php(60): XF\Mvc\Dispatcher->render(Object(XF\Mvc\Reply\View), 'html')
#12 src/XF/App.php(2351): XF\Mvc\Dispatcher->run()
#13 src/XF.php(517): XF\App->run()
#14 index.php(20): XF::runApp('XF\\Pub\\App')
#15 {main}
Request State:
Code:
array(4) {
  ["url"] => string(20) "/account/preferences"
  ["referrer"] => string(48) "https://codinghelp.site/forums/introductions.27/"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(0) {
  }
}

Also, in my email options section I have errors like this: DEBUG: Template option_template_emailSoftBounceThreshold not found.
This is an error in my user discouragement and discipline: DEBUG: Template option_template_preventDiscouragedRegistration not found.

This is all after I downloaded and re-uploaded the full zip for XF yesterday.

Edit/Update: Got this server error myself just browsing the admin panel:
Code:
ErrorException: Template error: [E_USER_WARNING] Template admin:option_template_preventDiscouragedRegistration is unknown
src/XF/Template/Templater.php:689

Generated by: DudeThatsErin
Jan 23, 2022 at 10:27 AM
Stack Trace:
Code:
#0 [internal function]: XF\Template\Templater->handleTemplateError(512, '[E_USER_WARNING...', '/home/u11027819...', 689, Array)
#1 src/XF/Template/Templater.php(689): trigger_error('Template admin:...', 512)
#2 src/XF/Template/Templater.php(1618): XF\Template\Templater->getTemplateData('admin', 'option_template...')
#3 src/XF/Template/Templater.php(1680): XF\Template\Templater->renderTemplate('option_template...', Array)
#4 internal_data/code_cache/templates/l1/s0/admin/option_macros.php(230): XF\Template\Templater->includeTemplate('admin:option_te...', Array)
#5 src/XF/Template/Templater.php(824): XF\Template\Templater->{closure}(Object(SV\StandardLib\XF\Template\Templater), Array, NULL)
#6 internal_data/code_cache/templates/l1/s0/admin/option_macros.php(501): XF\Template\Templater->callMacro('option_macros', 'option_row', Array, Array)
#7 src/XF/Template/Templater.php(824): XF\Template\Templater->{closure}(Object(SV\StandardLib\XF\Template\Templater), Array, NULL)
#8 internal_data/code_cache/templates/l1/s0/admin/option_list.php(77): XF\Template\Templater->callMacro('option_macros', 'option_form_blo...', Array, Array)
#9 src/XF/Template/Templater.php(1651): XF\Template\Templater->{closure}(Object(SV\StandardLib\XF\Template\Templater), Array, NULL)
#10 src/XF/Template/Template.php(24): XF\Template\Templater->renderTemplate('option_list', Array)
#11 src/XF/Mvc/Renderer/Html.php(50): XF\Template\Template->render()
#12 src/XF/Mvc/Dispatcher.php(460): XF\Mvc\Renderer\Html->renderView('XF:Option\\Listi...', 'admin:option_li...', Array)
#13 src/XF/Mvc/Dispatcher.php(442): XF\Mvc\Dispatcher->renderView(Object(XF\Mvc\Renderer\Html), Object(XF\Mvc\Reply\View))
#14 src/XF/Mvc/Dispatcher.php(402): XF\Mvc\Dispatcher->renderReply(Object(XF\Mvc\Renderer\Html), Object(XF\Mvc\Reply\View))
#15 src/XF/Mvc/Dispatcher.php(60): XF\Mvc\Dispatcher->render(Object(XF\Mvc\Reply\View), 'html')
#16 src/XF/App.php(2351): XF\Mvc\Dispatcher->run()
#17 src/XF.php(517): XF\App->run()
#18 admin.php(13): XF::runApp('XF\\Admin\\App')
#19 {main}
Request State:
Code:
array(4) {
  ["url"] => string(38) "/admin.php?options/groups/discourager/"
  ["referrer"] => string(42) "https://codinghelp.site/admin.php?options/"
  ["_GET"] => array(1) {
    ["options/groups/discourager/"] => string(0) ""
  }
  ["_POST"] => array(0) {
  }
}
 

Brogan

XenForo moderator
Staff member
If the file health check in the ACP passes then that confirms all of the files are okay.

Navigate to /install and rebuild the master data.
That should resolve any template related issues.
 

Erin Nicole

Member
That resolved those errors but now a new user is telling me this is happening on their desktop:image.png
The bar moves down for no good reason. This is in FireFox and Brave.

I use Brave and don't have this issue personally. No server errors come from this.

I'm using the XF default theme with minor extra.less edits and the same footer mod that is used on these forums.
 
Top