1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Forum / What´s New / it shows: "No results found."

Discussion in 'XenForo Questions and Support' started by erich37, Oct 9, 2010.

  1. erich37

    erich37 Well-Known Member

    when I click onto "Forum / What´s New" at my website, it does not show anything.

    It says "No results found." , although there are a few threads and posts already.

    Is there something wrong at my settings or is this normal when there are not that many threads yet ?
     
    Digital Doctor likes this.
  2. Brogan

    Brogan XenForo Moderator Staff Member

    If you have read all of the posts then there won't be anything new to display.

    Get someone else to post and then click on it.
     
  3. Blandt

    Blandt Well-Known Member

    what's new is relative to the user.
    What's new to you is nothing if you have read all threads ....
     
  4. erich37

    erich37 Well-Known Member

    it also shows "No results found." when not being logged-in.
    So it seems the "What´s new" is not relative to the user ?
     
  5. Blandt

    Blandt Well-Known Member

    If the threads are only for registered members then "no results found"
     
  6. erich37

    erich37 Well-Known Member

    not really, my friend......
     
  7. Blandt

    Blandt Well-Known Member

    I just checked your site out. and YES I'm Interested :D

    I would double check the forum permissions first .
    Let us know maybe it's a bug?
     
  8. erich37

    erich37 Well-Known Member

    Hey Blandt,

    I could not find any Forum-permissions which lets "not logged-in" visitors view/not view the "What´s New" section of the Forum.
    I have all settings as they come shipped as per default.......
     
  9. Brogan

    Brogan XenForo Moderator Staff Member

    What time was the last post made?
    I believe there is a time limit (not sure what) as browsing here as a guest only shows threads back to this morning.

    Make a new post and I'll check.
     
  10. erich37

    erich37 Well-Known Member

    yeah, seems to be a time-limit somewhere. Is there any chance to change that time-limit ?

    Many thanks,
     
  11. Digital Doctor

    Digital Doctor Well-Known Member

    I just went to a new XenForo site. First time there, I'm not logged in.
    Clicked on what's new?

    I got:
    No results found.

    Wow, that's quite the bad advertising for the site ?
    I guess not much happens here.

    For not logged in users, a "What's New" query should *NEVER* be "No results found".
    This should be fixed.

    New for not logged in users should be "list forum posts from most recent, backwards"
     
    erich37 and Brett Peters like this.
  12. erich37

    erich37 Well-Known Member

    well, theposts in "What´s New" are disappearing too fast.

    This is fine at a page like Xenforo with a lot of users and posts, but starting a Forum from Scratch this does not help.
    There should be an option to set a time as for how long posts are showing as being "New".
     
    Tomble and Digital Doctor like this.
  13. Dean

    Dean Well-Known Member

    General admin comment from me: Ummm, that would depend on how the admin want to set things up. Some people never join a site if they can read the content too easily.

    In addition every 'whats new' in a database search and with enough people doing that the load will increase.
     
  14. Dean

    Dean Well-Known Member

    I got your request to move this, but I really do think it would be better to try to figure out what is happening first. Then if you can get something specific pinned down, and the wording easy to understand, then make a separate suggestion. Suggestions really should be easy to read and understand.


    I believe there may be a few time limits. One of them is the database timeout limit where posts older than 28 days (the shipped default last I checked) are marked as read, regardless if they have been read or not. I believe it would be under: admincp -> options -> options somewhere.

    I can log in to my test account for you and find the exact place if you like.
     
  15. Brogan

    Brogan XenForo Moderator Staff Member

    What's New is set at 3 days/72 hours.

    if you want to change it then you need to edit library/XenForo/controllerpublic/findnew.php
    Look around line 102 for:
    PHP:
    if ($days 1)
       {
        
    $days 3;
       }
    If you want it be set to 5 days for example, change it to:
    PHP:
    if ($days 1)
       {
        
    $days 5;
       }
    It is possible that this might be an ACP option in the future :)
     
  16. erich37

    erich37 Well-Known Member

    please move this thread into "Suggestions".

    thanks.
     
  17. Brogan

    Brogan XenForo Moderator Staff Member

    erich37 likes this.
  18. erich37

    erich37 Well-Known Member

    is this build into XF Beta5 now ?
    I mean to change the time of how long posts appear in "What´s New" ?
     
  19. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    The current version is RC1.

    Threads stay in What's New until you read them. They will persist until you read them.

    If a thread remains unread for longer than 30 days then it will be automatically removed from the list. You can change the expiration time if you want:

    Admin CP -> Home -> Options -> Threads, Discussions and Conversations -> Read Marking Data Lifetime (Days)
     
  20. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

Share This Page