1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Forum not indexed by Google

Discussion in 'XenForo Questions and Support' started by xhuzen, Dec 10, 2013.

  1. xhuzen

    xhuzen Member

    Hi, we just noticed this one, but our community forums is not indexing by google.

    Here is our google_analytics template:


    What could be the problem?

    Thanks in advance!
  2. Jeremy

    Jeremy XenForo Moderator Staff Member

    The code you have posted a picture does nothing but provide you with analytics. Are you saying you aren't receiving analytic data?
  3. xhuzen

    xhuzen Member

    Yes, according to our google analytic account, our community forum is not crawling.
  4. xhuzen

    xhuzen Member

    What could be the problem? Why I am not receiving analytic data? Any help is much appreciated.
  5. Jeremy

    Jeremy XenForo Moderator Staff Member

    Have you set the appropriate google analytics Id?
  6. xhuzen

    xhuzen Member

    Yes, I have set it already in Statistics and Metrics -> Google Analytics Web Property ID
  7. Divvens

    Divvens Well-Known Member

    When have you activated and verified your website in Google Analytics? It sometimes needs time if it's newly verified and added.
  8. xhuzen

    xhuzen Member

    Its more than a month already, what could have i missed?
  9. Mike

    Mike XenForo Developer Staff Member

    Looking at your site, I see the analytics code being output and I can see it being grabbed and run when the page is loaded. Unfortunately, beyond that, I'm not sure what to suggest; if it appears that it's being run, then it'd be down to the data collection-side with Google.
  10. xhuzen

    xhuzen Member

    Actually our Xenforo is in subdomain, and I look at the google analytic webmaster tool and found a tracking code and replace the google_analytics template above with the code in the tracker. Here is a screenshot:


    does this info helpful about my issue?

  11. Jeremy

    Jeremy XenForo Moderator Staff Member

    I believe Google analytics updates every 24 hours. Does it show any data?
  12. xhuzen

    xhuzen Member

    It shows data now, i change the google_analytics template yesterday. Thanks for all your responds.

Share This Page