1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Forum hacked - Trying to fix

Discussion in 'Troubleshooting and Problems' started by Hunter Shenep, Oct 8, 2013.

  1. Hunter Shenep

    Hunter Shenep Member

    Hey guys,
    I wasn't exactly hacked, I just had an ex-staff member of mine out of anger try and destroy the forums.
    I have looked through many files, they are untouched, I have looked through all logs, and it seems the only thing he could have done was edit some stuff through MySQL.

    The only thing I can see that he did was delete the Nodes of the forums, all of the Threads and Replies seem to still be inside of the database.

    Here's what it looks like when I'm logged in:
    It's also like that for everybody. I can still login to the Admin panel.
    I have checked the permissions groups, and they seem all untouched, any body might know what's wrong?

    If you would like to see proof check http://diamcraft.com/forum1/
  2. Sheldon

    Sheldon Well-Known Member

    How many categories/forums did you have?
  3. Code Monkey

    Code Monkey Well-Known Member

    No backup? If you have a backup you could probably restore the nodes. Are you sure it's not a corrupt database table?
  4. Sheldon

    Sheldon Well-Known Member

    If you don't.....

    Once I deleted a node that had 2 categories, and around 5 forums. Didn't touch the threads.

    The next time I created a forum, the threads started to appear again. Cannot remember what I did, or if I did anything out of the ordinary though.
  5. infis

    infis Well-Known Member

    Try change and save all permissions for itself. It's rewrite permission combination in database.
  6. Hunter Shenep

    Hunter Shenep Member

    Like 10
  7. Carlos

    Carlos Well-Known Member

    Did this staff member have admin privileges when he was "staff?"

    The other thing to consider is: What hacks are vulnerable? Go to your ACP and do a file check in "tools."
    Last edited: Oct 8, 2013
  8. Sheldon

    Sheldon Well-Known Member

    You could try what I posted above. Like I said, I don't think I did anything different, just made another Category/Forum, and the threads started appearing again.
  9. Hunter Shenep

    Hunter Shenep Member

    Yes, I tried to add a category, even I still can't see it under forums, no permissions!
  10. Jeremy

    Jeremy XenForo Moderator Staff Member

    If you have a back up, I would revert it.
    AndyB likes this.
  11. MattW

    MattW Well-Known Member

    If you've added a category, and forum node, you'll still need to associate the thread with the new node_id, as they are linked together. You'll need to edit xf_thread and change the node_id in the table for each thread to be the new node_id that you have created where you want the thread to be.

    EDIT: Although, I came across this exact same problem when helping someone out here: http://xenforo.com/community/threads/xf_node-empty.60525/
  12. Hunter Shenep

    Hunter Shenep Member

    Hello, I actually did figure this out, but it still doesn't fix the permission problem..
  13. MattW

    MattW Well-Known Member

  14. Hunter Shenep

    Hunter Shenep Member

    That's from me trying to take bits of a clean database and transfer it to the old one. Didn't work out so well..

Share This Page