• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 Forum Error - Need Immediate Assitance

#1
Hey Guys/Developers,

We are facing a very problematic situation, as from time to time we receive an Error Message, and users are unable to access the forum.

VT - Forum - Error
The requested page could not be found.

unnamed.png

I have double checked the index route. Can you please help us out? I think there is something fishy that we are missing out.

Thanks.
 

Martok

Well-known member
#2
I'm not sure why you have an Index Page Route set in ACP > Options > Basic Board Information as you don't have a home page. Clicking on Home just leaves you on the forums page. Remove the Index Page Route.

I notice that you don't have Full Friendly URLs enabled. You can activate these on the same page, though do make sure you meet the requirements for this as detailed there.
 
#3
I'm not sure why you have an Index Page Route set in ACP > Options > Basic Board Information as you don't have a home page. Clicking on Home just leaves you on the forums page. Remove the Index Page Route.

I notice that you don't have Full Friendly URLs enabled. You can activate these on the same page, though do make sure you meet the requirements for this as detailed there.
I don't have anything in the Index Page Route. What else it can be? Enabling Full Friendly URLs will solve the problem?
 

Martok

Well-known member
#4
Apologies, I meant Home Page URL rather than Index Page Route. You need to leave Home Page URL blank to remove the Home tab, which you should do as you don't have a separate home page.

Full friendly URLs give nice URLs like you see here on the Xenforo site, so you'll no longer have index.php appearing on your forums page. Make sure you meet the requirements detailed in the option on the Basic Board Information page.
 
#5
Apologies, I meant Home Page URL rather than Index Page Route. You need to leave Home Page URL blank to remove the Home tab, which you should do as you don't have a separate home page.

Full friendly URLs give nice URLs like you see here on the Xenforo site, so you'll no longer have index.php appearing on your forums page. Make sure you meet the requirements detailed in the option on the Basic Board Information page.

Okay, I have left that field as blank now. I hope the error will be resolved now, and will not appear again. If it does appear again, I will again come back to you mate for help. Thanks :)
 
#6
Apologies, I meant Home Page URL rather than Index Page Route. You need to leave Home Page URL blank to remove the Home tab, which you should do as you don't have a separate home page.

Full friendly URLs give nice URLs like you see here on the Xenforo site, so you'll no longer have index.php appearing on your forums page. Make sure you meet the requirements detailed in the option on the Basic Board Information page.
The Error is still there. We have received it moments ago. Please help.
 

Tracy Perry

Well-known member
#7
The Error is still there. We have received it moments ago. Please help.
Have you checked your server error log (actual HTTP server - not the one in the ACP) for any associated errors? Is this on a shared hosting environment or VPS/dedicated server (if so, you can need to check your php logs also).
 

Tracy Perry

Well-known member
#9
If you have SSH access, ssh into the VPS and (depending on whether you are using apache, nginx, etc) view the log files
Apache2 is usually in /var/log/apache2/accesss.log for the access to the site and /var/log/apache2/error.log for errors

nginx is usually in /var/log/nginx/access.log for access to site and /var/log/nginx/error.log for errors
This will be different if you are using CentOS and Centminmod to have installed it as it makes the vhosts in the /home/nginx location and I think it puts the log files somewhere in there - I don't use CentOS and only help on one site that does.

OpenLiteSpeed is usually in /usr/local/lsws/<vhost defined>/logs/access.log for access and /usr/local/lsws/<vhost defined>/logs/error.log
Where <vhost defined> is what you told it the VHOST setup was in the config page for it.

PHP log is normally in /var/log/ and may be called php5-fpm.log or php5.log or something along that line. I doubt if it is really anything in there associated with it but better to be safe than sorry. It's most likely a configuration problem in the ACP of your forum for XenForo.
 
#10
If you have SSH access, ssh into the VPS and (depending on whether you are using apache, nginx, etc) view the log files
Apache2 is usually in /var/log/apache2/accesss.log for the access to the site and /var/log/apache2/error.log for errors

nginx is usually in /var/log/nginx/access.log for access to site and /var/log/nginx/error.log for errors
This will be different if you are using CentOS and Centminmod to have installed it as it makes the vhosts in the /home/nginx location and I think it puts the log files somewhere in there - I don't use CentOS and only help on one site that does.

OpenLiteSpeed is usually in /usr/local/lsws/<vhost defined>/logs/access.log for access and /usr/local/lsws/<vhost defined>/logs/error.log
Where <vhost defined> is what you told it the VHOST setup was in the config page for it.

PHP log is normally in /var/log/ and may be called php5-fpm.log or php5.log or something along that line. I doubt if it is really anything in there associated with it but better to be safe than sorry. It's most likely a configuration problem in the ACP of your forum for XenForo.
Mate I don't have SSH access. I also feel it has something to do with configuration in the ACP. Any suggestion?
 

Tracy Perry

Well-known member
#11
Mate I don't have SSH access. I also feel it has something to do with configuration in the ACP. Any suggestion?
OK, then you are on a shared hosting plan probably. Cpanel should have the ability to view the error log for the server (it did when I first started with HostGator way back).
Since it's only an intermittent error, it could be that your running up against resource allocation problems since if it was a configuration problem it would be consistent.
If you want to set up a temporary administrator account for me so I can log in and look at your ACP settings you can start a conversation with me and I'll provide logon details. If not, you can submit a ticket here and one of the support staff may be able to help.

EDIT:
Also, if you have not purchased the branding removal, I would suggest that you replace the copyright text per the license requirements.
 

Tracy Perry

Well-known member
#12
OK... just got the error also... when I went from the vestatrader.com.
Is this server an IIS server?
Answer - yes it is:
Code:
HTTP/1.1 200 OK Cache-Control: no-cache, no-store Pragma: no-cache
Content-Type: text/html; charset=utf-8 Expires: -1 Server: Microsoft-IIS/7.5
Set-Cookie: ASP.NET_SessionId=nh3siczjk0f1wktlchpczkr4; path=/; HttpOnly
X-AspNet-Version: 4.0.30319 X-Powered-B
It probably is going to end up being a server issue. I notice that you go from an secure connection to a non-secure connection on the site when you go to the forum from the main page. Don't know if this may be an issue. Someone familiar with IIS (I don't use it and wouldn't if I could) so I'll not be able to help there. Maybe @Slavik, @Mike or @Brogan may be more familiar with IIS and it's issues.
 
#15
OK... just got the error also... when I went from the vestatrader.com.
Is this server an IIS server?
Answer - yes it is:
Code:
HTTP/1.1 200 OK Cache-Control: no-cache, no-store Pragma: no-cache
Content-Type: text/html; charset=utf-8 Expires: -1 Server: Microsoft-IIS/7.5
Set-Cookie: ASP.NET_SessionId=nh3siczjk0f1wktlchpczkr4; path=/; HttpOnly
X-AspNet-Version: 4.0.30319 X-Powered-B
It probably is going to end up being a server issue. I notice that you go from an secure connection to a non-secure connection on the site when you go to the forum from the main page. Don't know if this may be an issue. Someone familiar with IIS (I don't use it and wouldn't if I could) so I'll not be able to help there. Maybe @Slavik, @Mike or @Brogan may be more familiar with IIS and it's issues.
Thanks man for your time. I appreciate it. I will get back to you.