1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Forum Down

Discussion in 'Troubleshooting and Problems' started by Ranger375, Feb 9, 2012.

  1. Ranger375

    Ranger375 Well-Known Member

    I can tell this isn't related to XF, but an old addon (that I uninstalled...or at least thought I did weeks ago) but for whatever reason my site is down.

    Fatal error: Class 'XenKingDir_ModerationQueueHandler_Listingclaim' not found in /home/shadowsp/public_html/vb/library/XenForo/Model/ModerationQueue.php on line 218


    Any idea what I can do to get around this?
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    The addon modified one of the handlers and apparently didn't change it back. Or maybe the handler was reverted but the cache wasn't rebuilt.

    Run these queries to fix the problem. Backup first:

    Code:
    INSERT INTO xf_content_type_field
    	(content_type, field_name, field_value)
    VALUES
    	('post', 'moderation_queue_handler_class', 'XenForo_ModerationQueueHandler_Post'),
    	('thread', 'moderation_queue_handler_class', 'XenForo_ModerationQueueHandler_Thread'),
    	('profile_post', 'moderation_queue_handler_class', 'XenForo_ModerationQueueHandler_ProfilePost')
    ON DUPLICATE KEY UPDATE
    	field_value = VALUES(field_value);
    
    UPDATE xf_content_type
    SET fields = ''
    WHERE content_type IN ('post', 'thread', 'profile_post');
    
    DELETE
    FROM xf_data_registry
    WHERE data_key = 'contentTypes';
    
    That will set the default handlers and clear the caches which will be automatically rebuilt. That should fix the error.

    I tested this myself. The only concern is if you still have an addon installed that needs a different handler from the default. If the first query returns zero rows then this is not a concern.
     
  3. Ranger375

    Ranger375 Well-Known Member


    Jake, I am getting this error when I run it:

    #1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'UPDATE xf_content_type SET fields = '' WHERE content_type IN ('post', 'thread', ' at line 10
     
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    It works for me. You can copy and paste all three queries together in the SQL tab in phpmyadmin.
     
  5. Ranger375

    Ranger375 Well-Known Member

    Weird.... I tried running them together and got that error. I tried separately and it worked. But query went through....but I am still getting the error :D
     
  6. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    I assume you don't have the XenKingDir addon installed anymore? Check in your:

    Admin CP -> Home -> List Add-ons

    What page generates this error? Is the page for a specific addon? Maybe the error is in reference to a content_type other than post/thread/profile_post, such as a content_type for an addon.

    If you are comfortable giving me FTP and admin access then I can take a look.
     
  7. Ranger375

    Ranger375 Well-Known Member

    Cool, I'd appreciate it. Info inbound
     
  8. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Fixed.

    There was a content_type called "listingclaim" which was apparently left over from that addon. I removed it and that fixed the error.
     
    Evina, Divvens, 3c and 1 other person like this.
  9. Ranger375

    Ranger375 Well-Known Member

    Thank you very much Jake. You've saved my forum yet again :D
     
    Digital Doctor likes this.
  10. Digital Doctor

    Digital Doctor Well-Known Member

    Make sure you report your issue with the addon in question.
     
  11. Ranger375

    Ranger375 Well-Known Member

    It was the XenKing Directory, but he already informed me that the latest version addresses it.
     

Share This Page