1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Forum crashed please help.

Discussion in 'Troubleshooting and Problems' started by ddnworg, Sep 4, 2012.

  1. ddnworg

    ddnworg Member

    today I had a error saying a table crashed "xf-sessions" and needed to be repaired. I did that. but I'm still getting errors and can't get my site up.


    Code:
    An exception occurred: Cannot send headers; headers already sent in /var/www/vhosts/politicalbuddies.com/httpdocs/library/config.php, line 1 in /var/www/vhosts/politicalbuddies.com/httpdocs/library/Zend/Controller/Response/Abstract.php on line 321
     
    Zend_Controller_Response_Abstract->canSendHeaders() in Zend/Controller/Response/Abstract.php at line 115
    Zend_Controller_Response_Abstract->setHeader() in XenForo/ViewRenderer/HtmlPublic.php at line 19
    XenForo_ViewRenderer_HtmlPublic->__construct() in XenForo/Dependencies/Public.php at line 193
    XenForo_Dependencies_Public->getViewRenderer() in XenForo/FrontController.php at line 499
    XenForo_FrontController->_getViewRenderer() in XenForo/FrontController.php at line 139
    XenForo_FrontController->run() in /var/www/vhosts/politicalbuddies.com/httpdocs/index.php at line 13

    please help
     
  2. high1976

    high1976 Active Member

    does acp > tools > file health check (admin.php?tools/file-check) throw out any problems (with index-files especially)?
    Anything in config.php before the opening <?php -tag?
     
  3. CyclingTribe

    CyclingTribe Well-Known Member

    AFAIK you can truncate the sessions table (empty it of all records) and it will simply mean everyone has to log back in again - but I'd like someone with a bit more knowledge to confirm that. (y)

    It might be a shortcut to resolving the problem if it's an issue with corrupt data in that table.
     
  4. ddnworg

    ddnworg Member

    I can't get to the ACP it gives me the same error

    Code:
    An exception occurred: Cannot send headers; headers already sent in /var/www/vhosts/politicalbuddies.com/httpdocs/library/config.php, line 1 in /var/www/vhosts/politicalbuddies.com/httpdocs/library/Zend/Controller/Response/Abstract.php on line 321
     
    Zend_Controller_Response_Abstract->canSendHeaders() in Zend/Controller/Response/Abstract.php at line 115
    Zend_Controller_Response_Abstract->setHeader() in XenForo/ViewRenderer/HtmlAdmin.php at line 17
    XenForo_ViewRenderer_HtmlAdmin->__construct() in XenForo/Dependencies/Admin.php at line 120
    XenForo_Dependencies_Admin->getViewRenderer() in XenForo/FrontController.php at line 499
    XenForo_FrontController->_getViewRenderer() in XenForo/FrontController.php at line 139
    XenForo_FrontController->run() in /var/www/vhosts/politicalbuddies.com/httpdocs/admin.php at line 13
     
  5. ddnworg

    ddnworg Member

    okay so what I had to do to get it back up and going

    had to edit the library/config.php the top line had a space in it.

    and then it gave me a error about the session table again. so emptied that and everything is back up and running.
     
  6. CyclingTribe

    CyclingTribe Well-Known Member

    Great stuff - glad to hear you've managed to sort it. (y)
     

Share This Page