1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Forum and Thread titles not showing

Discussion in 'Troubleshooting and Problems' started by descoteaux, Apr 6, 2012.

  1. descoteaux

    descoteaux New Member

    I think this is an easy one, but I've scoured the ACP and specifically Templates without result. For some reason my forum and thread titles are not showing and I don't recall ever trying to change them. I've also searched this forum for any related threads and gone through the Troubleshooting FAQ.

    This is a silly problem and it's embarrassing I can't fix it. I'd appreciate any advice. Thanks.


    threadtitles1.png threadtitles2.png
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Check these templates:

    Admin CP -> Appearance -> Templates -> PAGE_CONTAINER

    This code should be present:

    Code:
    						<xen:hook name="page_container_content_title_bar">
    						<xen:if is="!{$noH1}">						
    							<!-- h1 title, description -->
    							<div class="titleBar">
    								{xen:raw $beforeH1}
    								<h1><xen:if
    									is="{$h1}">{xen:raw $h1}<xen:elseif
    									is="{$title}" />{xen:raw $title}<xen:else
    									/>{$xenOptions.boardTitle}</xen:if></h1>
    								
    								<xen:if is="{$pageDescription.content}"><p id="pageDescription" class="muted {$pageDescription.class}">{xen:raw $pageDescription.content}</p></xen:if>
    							</div>
    						</xen:if>
    						</xen:hook>
    
    Admin CP -> Appearance -> Templates -> EXTRA.css

    Make sure you don't have any custom CSS that hides the titleBar, like this:

    Code:
    .titleBar
    {
    	display: none;
    }
    
     
    descoteaux likes this.
  3. descoteaux

    descoteaux New Member

    The code was there, however I reverted the PAGE_CONTAINER template to the default and now it's back. You indirectly nailed it. ;) Now I just need to figure out where I went wrong with my edits. Thank you a ton.



    EDIT: I figured it out. A month ago I wanted to remove the redundant forum title on the main page of the forum list. I managed to do that, but didn't realize it removed all other important titles.
     
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

  5. descoteaux

    descoteaux New Member

    Perfect. I removed the contents of the <xen:h1></xen:h1> tags and everything is how I wanted it a month ago (without my horrible mistake). You're fantastic.
     

Share This Page