• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Fixed font weight of text in posts and text editor

Mr Lucky

Well-known member
#1
I thought this would be obvious, ie under typography in Style properties, but changing the font weight there doesn't seem to affect it.

Can anyone please help?
 

Mike

XenForo developer
Staff member
#2
They're not overridden from the "normal" font weight all the way back at the root element.

They should only be set to whole hundreds values (100, 200, ... 900). It's a bug that the input lets you set them to values between this.

Note that what levels show differently will vary between devices and fonts used.
 

Mr Lucky

Well-known member
#3
They're not overridden from the "normal" font weight all the way back at the root element.

They should only be set to whole hundreds values (100, 200, ... 900). It's a bug that the input lets you set them to values between this.

Note that what levels show differently will vary between devices and fonts used.
That is what I'm doing, I change normal font to 500 from 400 - no difference. Not even any difference if I change to 700. (Testing also with default style)
 
Last edited:

Mr Lucky

Well-known member
#4
Well, this works

CSS:
.message-body

{font-weight:500}
but seems odd that I need to do that when there is a style property
 

Mike

XenForo developer
Staff member
#5
Yeah, that would appear to be a bug. We'll need to add this explicitly in our CSS for consistency.