FollowupTO @021 "Google"...

Masetrix

Well-known member
Answer to: https://xenforo.com/community/threads/cscn-debug-defender.195549/post-1543924
Please respect @ShikiSuen and do not lead their topic offtopic....

I don't use Google search for such things, I use the forum search and if this search spits out results for XF 1.x then I ignore such results because XF1 and XF2 are, from the point of view of non-developers, incompatible. ☠️

By the way, I don't use online banking or admin accounts or things like that on my mobile phone or tablet because Android and Windows distribute too much of my data ... But that would be another topic now... ;)
 

Dixie McCall

Well-known member
@ShikiSuen I post this not out of unkindness to you but as someone not on equal ground in terms of my code experience, I clearly need understanding and patient Devs to help me out from time to time, not ones that have a propensity to take things personally and get bent out of shape so easily. :)
 

ShikiSuen

Well-known member
@ShikiSuen I post this not out of unkindness to you but as someone not on equal ground in terms of my code experience, I clearly need understanding and patient Devs to help me out from time to time, not ones that have a propensity to take things personally and get bent out of shape so easily. :)
I always do as what my customer told me to do. He doesn't want his website to be turned off because he treats his website as important as the power supply of a hospital. There are also some template pages which won't be triggered on your local dev machine.

My initial intent is to enable dev mode but disable the debug mode. It occurred to me that this is not applicable. Enabling dev mode on a hot site surely brings vulnerability by default, and my add-on disables that vulnerability to all visitors (except those who have sufficient adminCP access).

There are some adminCP settings that require debug mode to edit, especially the template modifications (which is the most troublesome). My add-on made sure no one in the front can notice that the debug / dev mode is enabled.

Still, I always turn off these modes as soon as I finish editing.
 
Top