1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Partial Fix Firefox 37.0.2 - won't allow uploads when 18 or more file extensions specified in XF attachements

Discussion in 'Resolved Bug Reports' started by CyclingTribe, May 1, 2015.

  1. CyclingTribe

    CyclingTribe Well-Known Member

    Ideally I need someone else to test this, but I recently added a new file extension to CycleChat taking the total from 17 to 18 extensions; zip txt pdf png jpg jpeg jpe gif gpx doc docx xls xlsx kml tcx fit csv mobi

    Having done so I got support threads that people couldn't upload with FF anymore. IE and Chrome, no problem, but when users clicked the Upload button in FF there were no files shown.

    I thought it might be baulking at the .mobi extension so I removed it and, hey presto, the files re-appeared. However, as a test, I added a different extension and once again the files disappeared from the right-side file pane.

    Note: You need to do a page refresh after changing the extensions in the XF ACP!

    After experimenting it seems that with 17 extensions FF will show available files for upload; but with 18 the file window is blank (even if there are qualifying file types).

    Would someone please be kind enough to test this on their own sites to confirm?

    Even if it turns out to be a FF issue, I'd still like to rule out XF and my add-ons!

    Thanks,
    Shaun :D
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    I just added some random extensions up to 20 and it still works for me.
     
    CyclingTribe likes this.
  3. Brogan

    Brogan XenForo Moderator Staff Member

    One interesting quirk however, is the directory in the modal window changes, depending on the extensions added as allowed file types :confused:
     
  4. CyclingTribe

    CyclingTribe Well-Known Member

    Thanks - I'll experiment with disabling add-ons later to see if it's possibly one of those that is causing this. Just seems really odd and unexpected behavoiur.
     
  5. CyclingTribe

    CyclingTribe Well-Known Member

    Would you mind trying it with this specific extension list:

    zip txt pdf png jpg jpeg jpe gif gpx doc docx xls xlsx kml tcx fit csv mobi

    Does it have the same affect on your site with these as the allowed attachement types list? No files displayed?
     
  6. Chris D

    Chris D XenForo Developer Staff Member

    I have a feeling we've seen this before.

    Was it something to do with query string length?

    In which case, @Brogan, did you try with the same extensions as Shaun? He has a few four character extensions so that may be relevant.

    IIRC it was a browser limitation or a configuration option in FF.
     
    CyclingTribe likes this.
  7. Brogan

    Brogan XenForo Moderator Staff Member

    Still works fine for me using that list of extensions.
     
    CyclingTribe likes this.
  8. Crazy-Achmet

    Crazy-Achmet Active Member

    File uploads also suddenly stopped working for me. I can't attach an image here or on my forum, other members don't have a problem.

    Firefox 39.0a2
     
  9. Mike

    Mike XenForo Developer Staff Member

    I have managed to reproduce this, though I'm not clear why it's happening. I've managed to workaround this because we were duplicating the allowed extensions in lower and upper case and I don't see that being necessary any longer (doesn't make a difference in my tests). So I'll go with that, but otherwise it seems like a browser issue.
     
    CyclingTribe and Chris D like this.
  10. CyclingTribe

    CyclingTribe Well-Known Member

    Just curious - did this fix make it into 1.4.7?
     
  11. Chris D

    Chris D XenForo Developer Staff Member

    Yes, should have done.
     
    CyclingTribe likes this.
  12. CyclingTribe

    CyclingTribe Well-Known Member

    Nice one - thanks. (y)
     

Share This Page