1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 find-new/threads/ not working

Discussion in 'Troubleshooting and Problems' started by sinful, Dec 29, 2011.

  1. sinful

    sinful Member

    Hi,

    I have recently migrated from an apache server to a litespeed server. Everything went ahead smoothly except that one page could not load after the migration - the What's New page.

    When accessing find-new/threads/ , the page is blank.

    Help would be appreciated. Thanks!

    P/S I added this new line to the .htaccess after the migration. Because without it, the main page would display my service provider's "under construction page".
    Code:
    DirectoryIndex index.php index.htm index.*
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    A blank page is often a suppressed error. Try adding this line to your library/config.php file:

    Code:
    ini_set('display_errors', true);
    
    That may reveal an error message on the blank page.
     
  3. sinful

    sinful Member

    Which part of the config file should I add this line?

    I added the line at the top of the config file and every other link seems to get the unexpected error occurred message. For the find-new/threads page, this is the error message I've got:

    ini_set('display_errors', true); An unexpected error occurred. Please try again later.
     
  4. sinful

    sinful Member

    okay i've got this under my server error log:
    Code:
    ErrorException: Cannot modify header information - headers already sent by (output started at /home2/gymkakic/public_html/library/config.php:2) - library/MaxViewGuests/Model/Thread.php:21
    Generated By: Unknown Account, Yesterday at 10:46 PM
     
     
    Stack Trace
     
    #0 [internal function]: XenForo_Application::handlePhpError('num_views', '8', 1325173577, '/')
    #1 /home2/gymkakic/public_html/library/MaxViewGuests/Model/Thread.php(21): setcookie(Array, Array, NULL, Array, Array)
    #2 /home2/gymkakic/public_html/library/XenForo/Model/Thread.php(619): MaxViewGuests_Model_Thread->canViewThread(Array, Array, NULL, Array)
    #3 /home2/gymkakic/public_html/library/XenForo/ControllerPublic/FindNew.php(139): XenForo_Model_Thread->canViewThreadAndContainer()
    #4 /home2/gymkakic/public_html/library/XenForo/ControllerPublic/FindNew.php(15): XenForo_ControllerPublic_FindNew->findNewThreads()
    #5 /home2/gymkakic/public_html/library/XenForo/FrontController.php(310): XenForo_ControllerPublic_FindNew->actionThreads(Object(XenForo_RouteMatch))
    #6 /home2/gymkakic/public_html/library/XenForo/FrontController.php(132): XenForo_FrontController->dispatch()
    #7 /home2/gymkakic/public_html/index.php(13): XenForo_FrontController->run()
    #8 {main}
     
     
    Request State
     
    array(3) {
      ["url"] => string(35) "http://gymkaki.com/find-new/threads"
      ["_GET"] => array(0) {
      }
      ["_POST"] => array(0) {
      }
    }
    
     
  5. Brogan

    Brogan XenForo Moderator Staff Member

    Do you have an add-on called Max View Guests (or similar) installed?

    Try disabling that and see if it works then.
     
  6. sinful

    sinful Member

    Yes i do. I have tried turning off the Limited Guest Viewing by borbole under options, but to no avail.

    here is another error log for find-new/threads:
    Code:
    Error Info
    Zend_Controller_Response_Exception: Cannot send headers; headers already sent in /home2/gymkakic/public_html/library/config.php, line 2 - library/Zend/Controller/Response/Abstract.php:321
    Generated By: Unknown Account, Yesterday at 10:46 PM
     
     
    Stack Trace
     
    #0 /home2/gymkakic/public_html/library/Zend/Controller/Response/Abstract.php(115): Zend_Controller_Response_Abstract->canSendHeaders(true)
    #1 /home2/gymkakic/public_html/library/XenForo/ViewRenderer/HtmlPublic.php(19): Zend_Controller_Response_Abstract->setHeader('Content-Type', 'text/html; char...', true)
    #2 /home2/gymkakic/public_html/library/XenForo/Dependencies/Public.php(190): XenForo_ViewRenderer_HtmlPublic->__construct(Object(XenForo_Dependencies_Public), Object(Zend_Controller_Response_Http), Object(Zend_Controller_Request_Http))
    #3 /home2/gymkakic/public_html/library/XenForo/FrontController.php(499): XenForo_Dependencies_Public->getViewRenderer(Object(Zend_Controller_Response_Http), 'html', Object(Zend_Controller_Request_Http))
    #4 /home2/gymkakic/public_html/library/XenForo/FrontController.php(139): XenForo_FrontController->_getViewRenderer('html')
    #5 /home2/gymkakic/public_html/index.php(13): XenForo_FrontController->run()
    #6 {main}
     
     
    Request State
     
    array(3) {
      ["url"] => string(35) "http://gymkaki.com/find-new/threads"
      ["_GET"] => array(0) {
      }
      ["_POST"] => array(0) {
      }
    }
    note that these error only logs when i added the line that Jake told me to add in the library/config file. After removing that line, the Server Error Logs doesn't log any more errors.
     
  7. Brogan

    Brogan XenForo Moderator Staff Member

    Did you add the line before the <?php ?

    It needs to be after that.
     
  8. sinful

    sinful Member

    Okay i've tried adding the line
    Code:
    ini_set('display_errors', true);
    after <?php

    There seem to be no error on the /find-new/threads page. And no error is logged under Server Error Logs.
     
  9. Brogan

    Brogan XenForo Moderator Staff Member

    How many add-ons do you have installed?

    You will need to disable each one in turn to see if it's one of those causing the problem.

    You can also try it in a default, unedited style, which will indicate whether it is an issue with your custom style.
     
  10. Digital Doctor

    Digital Doctor Well-Known Member

    Would it be a good idea to have display_errors true set as the default ?
    If an error was displayed, people could read it and start the troubleshooting process themselves ?
     
  11. sinful

    sinful Member

    Okay I have did what you mentioned. It seems like the Limited Guest Viewing add-on is causing the problem. Sorry for being unclear in the previous post, I turned it off under options instead of disabling it totally. After disabling it totally, the find-new/threads page is working.

    So I guess the problem lies in the Limited Guest Viewing add-on interfering with a litespeed server somehow :confused:

    thanks for your help (y)
     
  12. account8226

    account8226 Guest

    I just switched to Litespeed and had that problem.

    Have you found any solution ? This add-on is really usefull.
     
  13. sinful

    sinful Member

    Unfortunately no. I ended up disabling the add-on.

    If you do find a solution, please drop me a message! ;)
     

Share This Page