1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 File upload - empty file browser window

Discussion in 'XenForo Questions and Support' started by Neil E., Mar 28, 2015.

  1. Neil E.

    Neil E. Active Member

    I have attachments set up to allow GPS files (gpx,gdb etc.) to be uploaded. I can attach them no problem. One user states that when he tries, his file browser window is empty when he goes to find the file. I've checked permissions and he should be able to do this.

    What is the consequence of a disallow permission for file uploads? Missing the "upload a file button"? Does the empty file browser indicate my set up is wrong?
  2. Mike

    Mike XenForo Developer Staff Member

    The file browser (with Flash) limits to the allowed file extensions. I do vaguely recall a report from ages ago that someone said not all extensions were showing up, but it wasn't something I could ever reproduce; they seemed to imply it was Firefox-specific. Other than passing in the allowed file extension, we really have no control over the OS file picker. He may be able to attach the file directly by typing the name or he can disable the Flash uploader.

    I'm not sure what you mean by this. If you don't have permission to upload files, you won't see the upload button.
  3. Neil E.

    Neil E. Active Member

    That is exactly what I wanted to confirm.

    This issue was directly related to the Flash uploader. With it unchecked in the user's preferences, the attachments were visible and could be uploaded.

    What does the Use Flash Uploader checkbox do on the Attachment Options page? How is it different than the user preferences?

    As part of testing, I gave the user custom permissions. How do I revert him back to having the permissions from his usergroup (remove the custom permissions)?
  4. Sunka

    Sunka Well-Known Member

    That was my problem and strange solution was to delete that custom added allowed extensions in ACP for attachment, and save it, and then add it again but not at same order.
    Also, another problem was when same extension added twice.

    All in all, xenforo have strange behaviour when saved allowed attachment extensions with flash uploader enabled. Sometimes it seems that for not known reason extensions are not saved.

    Try to save it couple of times, and in some random order, that could fix problm
  5. Mike

    Mike XenForo Developer Staff Member

    It's simple a global control.

    Go to edit the user-specific permissions and use the "quick check" option to reset them to not set or inherit.
  6. Neil E.

    Neil E. Active Member

    Thanks Mike.
  7. Neil E.

    Neil E. Active Member

    I did this (quick check = not set), but he stills shows in the "User Permissions" list.
  8. Brogan

    Brogan XenForo Moderator Staff Member

    Ensure any numerical options are also reset to the default.

    Those need to be done manually.
  9. Neil E.

    Neil E. Active Member

    I need more detail please. What is a numerical option? I only changed permissions and unchecked the flash uploader.

    EDIT: Ok I understand, one of the limit boxes was set to a value other than 0.
    With this corrected, he is no longer in the user permission list.

    Thank you.
  10. Brogan

    Brogan XenForo Moderator Staff Member

    Numerical options such as this:
  11. Neil E.

    Neil E. Active Member

    Brogan you are blazing fast, you answered before I got my EDIT done. Thanks.

Share This Page