XF 2.2 Unable to upgrade through OneClick or through file upload

Satal

New member
I've created a test version of my site (test.mydomain.com) with users' ability to view the forum disabled, to have an environment where I can test upgrades etc on. However, I've just been trying to test the upgrade from 2.2.9 to 2.2.10 Patch 1 and I can't seem to do it.

OneClick upgrade
The obvious approach is to use the OneClick upgrade process, which I've seen a lot of people benefiting from. However, when I try running it I get the error message below. This is even with the owner of the folder being set to nginx:nginx (chown nginx:nginx -R [path to root of forum domain])
The following issue was found when determining if a one-click upgrade is possible: The files are not writable.

Please download this version from the XenForo customer account area and upgrade manually. For more information on the upgrade process, please see the XenForo manual.
While I wouldn't have tried it on my main site, I've even chmoded to 777 to check if this would resolve it (chmod -R 0777 [path to root of forum domain], I've also validated that it was applied). However, I still get the error message then.

Manual upload of files
Following that not working, I decided that I would use the older route of uploading the files manually. I downloaded the latest files from the XenForo customer area extracted them on my PC and uploaded the contents of the upload folder to the public folder on the VPS. However, when I go to test.mydomain.com/install and log in, I am greeted with the message:
You are already running the current version (2.2.9). To do a fresh install, click here.
For the avoidance of doubt, I've confirmed that I'm connected to the correct VPS and also that I'm uploading the files to the correct domain on the VPS. I've even checked my DNS to confirm that the domain is pointing to that VPS and I haven't messed that up somehow.

I'm genuinely at a loss at this point on how I'm supposed to complete the upgrade or if I'm missing something very obvious. Any suggestions are greatly appreciated.
 

Satal

New member
Can the site see out into the Internet? 2.2.9 is not the current version (presumably you manually downloaded 2.2.10 patch 1)?
The site can see out to the Internet.

Correct, I downloaded 2.2.10p1. The problem I'm facing is that despite having uploaded the new version it doesn't suggest that I can perform the upgrade :(
 

Satal

New member
Ok, so I've figured it out and embarrassingly, it's 100% preventable user error. As I was running out of space, I moved the test domain's root folder to a mounted Digital Ocean volume but had unforgivably failed to remove the old files from the standard location. This meant I was looking in the usual location and seeing the regular files, but changes to them wasn't making a difference.

Thanks, @VBX Co for your help
 

VBX Co

Active member
Nice one, glad it’s sorted. Most of us have done similar before, that “Oh noooo!!” moment when you realise you’ve overlooked something that might otherwise have been obvious. :)
 
  • Like
Reactions: ENF
Top