1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 File upload broken

Discussion in 'Troubleshooting and Problems' started by Tom7, Jul 29, 2013.

  1. Tom7

    Tom7 New Member

    Forum members, moderators and even Admins cannot upload files to forum posts. We used to be able to, but now it's not working.

    The progress bar acts as if everything is fine, then we get the message:
    Screen Shot 2013-07-29 at 12.32.19 PM.png
    Apparently the latest file upload was May 13, 2013

    Screen Shot 2013-07-29 at 1.55.25 PM.png

    I believe that was before the forums were migrated to a new webhost by the webhost (siteground), so I thought it might be folder/file permissions. I went to the file structure and found the /data and /internal_data folders were set at 755. Researching other threads here, I learned that they should be 777 (and all their children files and folders) so I have made that change but I still keep getting this error.

    Are there other things that are supposed to be 777 as well?

    As for as the control panel is concerned, everything is right in the attachments area.

    And as for the file types as sizes, the files we are trying to upload PDFs (in the allowed list), and are well under the thresholds set, a file health check reports that all 1,064 files are fine...

    I'm not sure where to go now. Does something have to be rebooted or restarted for the new file permissions to take effect?

    I have logged out of my forums and cleared the cache in case that might help, but nope.

    Thanks for your help, guys.
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Does it work if you disable the flash uploader?

    Check the mod_security settings.
     
    Tom7 likes this.
  3. Tom7

    Tom7 New Member

    Interesting! I disabled the Flash uploader and am now able to upload files! Thanks!

    We can make do without it, but if there is a way to have it, that would be good too.
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Try adding this to the .htaccess file:
    Code:
    <ifModule mod_security.c>
    SecFilterEngine Off
    </ifModule>
    Then re-enable the flash uploader and see if it works.
     
    Tom7 likes this.
  5. Tom7

    Tom7 New Member

    Thanks again!
     

Share This Page