1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Figuring out queries..

Discussion in 'XenForo Questions and Support' started by Glockie, Dec 12, 2015.

  1. Glockie

    Glockie Well-Known Member

    Hello all,
    Dubious question really but is there a way of working out what queries are requested on any given page load?
    I ask because I am trying to cut back on add-ons and trim the fat, doing well so far as site speed on desktop is very good, even though very buggy in Firefox :p
    However mobile is very quick, but I know it can be faster. (it's on 88 or so) and have had 95 before.

    So with debug enable here are my stats;
    Timing: 0.6153 seconds Memory: 32.558 MB DB Queries: 144

    Just wondering is there a way of being able to work out what actually the 144 queries are?
    Would appreciate any tips and pointers.

    Many thanks in advance..
     
  2. wang

    wang Well-Known Member

    144 queries is on the high side. You can view the queries by clicking on the time link at the footer of your forum.

    queries.png
     
    Glockie likes this.
  3. Glockie

    Glockie Well-Known Member

    Yeah I tried that but it does nothing apart from reload the page really..
     
  4. wang

    wang Well-Known Member

    Is the link not clickable? Or it is, but it does not output anything?
     
  5. Glockie

    Glockie Well-Known Member

    Yes it's clickable, but only refreshes the page. I have seen this behaviour with many other people too who also faced the same issue of timings not displaying anything.
     
  6. EQnoble

    EQnoble Well-Known Member

  7. Glockie

    Glockie Well-Known Member

    No, just reloads the forum index.
    I have seen this all over XF and it seems a lot can't get anything else either....
     
  8. Chris D

    Chris D XenForo Developer Staff Member

    There was what appeared to be an unfixable bug in my Enable Debug from Admin Home add-on which exhibited this behaviour.

    The workaround is to enable debug mode in config.php the traditional way but my add on will properly disable it when you toggle it off in the Admin CP.
     
    Glockie likes this.
  9. Glockie

    Glockie Well-Known Member

    Okay Chris and thank you for letting me know.
     

Share This Page