• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Fixed [FF] Can't paste on the rich text editor (random)

AndyB

Well-known member
#5
Mac Firefox

1) Reply to Conversation
2) Type in some text below the quote
3) Open new tab navigate to Resources
4) Select add-on
5) Copy URL
6) Go back to Conversation tab
7) Try to paste URL is not possible in Rich mode, must switch to BB Code Editor to paste URL
 

markku

Well-known member
#6
Mac Firefox

1) Reply to Conversation
2) Type in some text below the quote
3) Open new tab navigate to Resources
4) Select add-on
5) Copy URL
6) Go back to Conversation tab
7) Try to paste URL is not possible in Rich mode, must switch to BB Code Editor to paste URL
I tried the steps, and I was able to paste the URL.

However, I have come across this "can't paste" bug a couple of times, seemingly happening totally randomly. (Mac Firefox 28.0, XF 1.3.0 and 1.3.1).

The "fix" for me has always been, same as your suggestion, switching to BB Code editor and pasting the content there. Also, after coming back from the BB Code Editor to the Rich mode, I could again paste text.
 

AndyB

Well-known member
#7
Yes it appears to be random. I just wanted to post the steps so Mike would know exactly what I did, hopefully the information will help him isolate the problem.
 

Mike

XenForo developer
Staff member
#8
I'm not sure I reproduced this specifically, but I did reproduce something that may be related. I've just rolled the change out here, so please let me know if you run into this again.