1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 fatal error

Discussion in 'Troubleshooting and Problems' started by topcat, May 22, 2014.

  1. topcat

    topcat Well-Known Member

    Got the error below. I have just moved servers from a server I had been on for years with my vbulletin forums, and all edit I had done previously have been lost. Is there anything I need to do server side to solve this

    ErrorException: Fatal Error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 23744 bytes) - library/XenForo/Template/Compiler/Statement/Raw.php:17
    Generated By: Unknown Account, Tuesday at 5:01 AM
    Stack Trace
    #0 [internal function]: XenForo_Application::handleFatalError()
    #1 {main}
    Request State
    array(3) {
    ["url"] => string(33) "http://xxxxxxxx/deferred.php"
    ["_GET"] => array(0) {
    ["_POST"] => array(4) {
    ["_xfRequestUri"] => string(10) "/index.php"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfToken"] => string(8) "********"
    ["_xfResponseType"] => string(4) "json"
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Your server is hitting the PHP memory_limt.

    Ask your host if they can increase it.
  3. topcat

    topcat Well-Known Member

    Can I not do this myself. I have root access. probably did it a while a go on old server, just forgot.

    is it in php.ini or something
  4. Tracy Perry

    Tracy Perry Well-Known Member

    I believe it is the memory_limit = setting in php.ini. I have mine at 256MB.
  5. Chris D

    Chris D XenForo Developer Staff Member

    There's also a similar setting in Lightspeed that can override the setting in php.ini.
  6. Brogan

    Brogan XenForo Moderator Staff Member

    XenForo does try to increase the limit but the server probably doesn't allow it in this case.
  7. topcat

    topcat Well-Known Member

    cheers was set at 32m, set it to 256 for now, cheers

Share This Page