1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Facebook set up help

Discussion in 'Custom Service/Development Requests' started by kortia, Apr 1, 2012.

  1. kortia

    kortia Member

    Willing to pay somone to set up facebook integration so people can sign in with there facebook.

    you can email me rod at kortia.com
  2. Floris

    Floris Guest

    Facebook integration is default, and fairly easy to set up. You don't need to pay anybody for this.
  3. kortia

    kortia Member

    Nice I will take a look. Every time I click associate with face book it says :

    "error": {
    "message": "Invalid redirect_uri: Given URL is not allowed by the Application configuration.",
    "type": "OAuthException",
    "code": 191
  4. kortia

    kortia Member

    I also did add the application ID and password
  5. Floris

    Floris Guest

    admin.php > options > Facebook integration

    Click on the link to open Facebook dev site, from where you click create new app

    Example data:
    App name: xfdemo122
    App namespace: xfdemo
    And submit it.


    You now get a page with the api key/secret, copy it over to xenforo's fb integration page:

    Before you submit it on xenforo, first, on Facebook, click on "edit app" in top right, and select "use to login on website"

    Here you set the url to your site, I have xenforo for example on http://xenfans.com/ so that's what I enter. Note, that the domain or path has to end with trailing /

    Submit the app edit changes, and then submit the xenforo changes.

    You should be set now.
    Brett Peters likes this.
  6. kortia

    kortia Member

    I cannot tlel you thank you enough. I see the problem I am having. For some reason when I put http:// or www. in front of the url it will not work. If I type the domain name with out http:// or www. in front of the domain name the browser it will work.
    I have never had anything like this happen before.
  7. Floris

    Floris Guest

    As long as it is solved.
  8. kortia

    kortia Member

  9. kortia

    kortia Member

    it is not solved ... it will not let me add the domain name under app domain
  10. kortia

    kortia Member

    I have submitted a ticket, 10 million thank yous. :)
  11. Floris

    Floris Guest

    leave the index.php out
  12. Brogan

    Brogan XenForo Moderator Staff Member

  13. kortia

    kortia Member

    Thanks Brogan, I understand how it works, I think I have a DNS issue. The A file more than likely. This forum rocks!

    Floris remove from where? is this the ht access file? Im not even sure what file it is installed in the sql data base.

    if I go straight to www.community.hennahut.com the site will not work at all. I ahve to use http:// or not http://
    the www. is what is wrong, so when I go to set it up in facebook, facebook app says it is nto a valid domain name.

    I do not have access to the DNS so I have them looking into it.
  14. Andrej

    Andrej Well-Known Member

    You need to remove the part in red from the URL, or else your app domain won't get approved and you will get the error you quoted.
  15. Floris

    Floris Guest

    To my knowledge it requires the full url, including http:// and a trailing slash. So no index.php or other files specifically.
  16. kortia

    kortia Member

    It is only www.community.hennahut.com that will not work.
    @Andrej, how do I remove the index.php? Do I do this via FTP? Or in my admin panel?
  17. kortia

    kortia Member

    Or you mean remove it in the facebook side. I have done so and it still says it is not a valid domain name. Maybe I will try setting up a whole new app.
    But the fact remains if you use "www" to go to the site it will not work.
  18. kortia

    kortia Member

    well HMMMM seems to be working now. I just signed up through facebook.

    I looked it up, here is the skinny so it may help somone else.

    In the Site domain name, I used www.Hennahut.com (not community.hennahut.com) the site URL http://community.hennahut.com ( I would think that comunity.hennahut.com would be the "domain" name.
    then canvas url is community.... and secure canvas community... so I had to use the domain name not the subdomain when building the app :)

    Thank you all for the help!!! I would have never figured it out with out you guys!
    zRnM likes this.
  19. DBA

    DBA Well-Known Member

    Leave the www off, community is your sub domain.

  20. Luis

    Luis Well-Known Member

Share This Page