1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Facebook Open Graph Logo not shown when sharing

Discussion in 'Troubleshooting and Problems' started by HenrikHansen, Feb 20, 2014.

  1. HenrikHansen

    HenrikHansen Well-Known Member

    I cannot make the Facebook Open Graph Logo be shown on Facebook when sharing.

    For the time being, I am using the default setting "styles/default/xenforo/logo.og.png". Any ideas?
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    HenrikHansen likes this.
  3. Martok

    Martok Well-Known Member

    How strange. Mine is working just fine.
    https://developers.facebook.com/tools/debug/og/object?q=www.seniorgamers.net

    It seems an odd error on yours:

    That suggests that it's trying to use another image which isn't big enough so it's using the one at that URL instead.

    So instead of using http://cliptheapex.com/styles/cliptheapex/xenforo/logo.og.png
    it's using
    http://cliptheapex.com/styles/cliptheapex/images/logo.png

    I assume you have set the Facebook Open Graph Logo path correctly in Appearance Style Properties > Header and Navigation?

    Could it be anything to do with you using your own style and it somehow looking in the wrong place e.g. the default style?
     
    Citizen likes this.
  4. HenrikHansen

    HenrikHansen Well-Known Member

    In my case, I have reset the property to Xenforo default, so it actually does not look the wrong place
     
  5. Martok

    Martok Well-Known Member

    I assume you've placed your logo.og.png file in there too (which would get overwritten on upgrades)?

    Mine is in a separate folder in the root ie not in styles/

    http://www.seniorgamers.net/snr/logo.og.png
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    That's the weird thing @Martok, it used to work and I haven't changed anything.

    It's just typical random FB weirdness.
     
  7. Martok

    Martok Well-Known Member

    This hasn't by chance broken since you upgraded to Xenforo 1.3 beta? If so, could it be anything to do with the proxying?
     
  8. Brogan

    Brogan XenForo Moderator Staff Member

    I have no idea when it stopped working - I never click the FB buttons :D

    I have however just changed the path from @imagePath/xenforo/logo.og.png to styles/cliptheapex/xenforo/logo.og.png

    It doesn't appear to have made any difference.

    Meh! Who cares.
     
  9. FredC

    FredC Well-Known Member

    Mine wasn't pulling the logo og file until i configured FB in the options completely..
     
  10. Brogan

    Brogan XenForo Moderator Staff Member

    Mine has been fully configured from the start.
    It used to work fine, it doesn't any longer.
     
  11. shinyfirefly

    shinyfirefly Member

  12. airbrushtutor

    airbrushtutor Member

    Does this still not work?? i've changed the image in every part of my site, all style templates, it's set to the default but i still get the xenforo image displaying :( There's no xenforo image left in the site.. and it's only an 800kb file the xenforo image - is it generated dynamically or something?
     
  13. Chad

    Chad Active Member

    I'm having a similar problem . Where in XF admin panel would you update the location of the op:graph logo file? I can't find it.

    Using the FB debug tool for http://www.talkjesus.com https://developers.facebook.com/tools/debug/og/object/

    I fetch new scape info without a problem, except one last thing that just won't kick in. The op:graph image shows default Xenforo pic instead of mine. However, the weird thing is if you click the link, it'll actually show my version (chat icon with 3 people group). It still pulls old XF pic too if I try to post on FB. I've confirmed with XF support it's not them, obviously anyway.

    Any idea?
     
  14. Brogan

    Brogan XenForo Moderator Staff Member

    It is entirely down to Facebook.
    You will have to wait until their server cache updates.

    It tool several months for exactly the same problem to resolve on my site.
     

Share This Page