• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.1 Facebook logo

OverHere

Active member
#1
av (2).jpg

recc.jpg

In the first attached photo you can see a small XenForo logo flanked by the avatar box. On my site at satisfy.tv I need to insert my own logo in the same place, which is currently blank (2nd photo). Where and how is this done?

Thank you.
 

Ernest L. Defoe

Well-known member
#2
@OverHere to change that logo you will need to change the image located in the styles/xenforo/ directory. The file you need to change with your own logo is logo.og.png. You can specify another name in the ACP I believe but it's easier to just change the file name of the image you want to show there to logo.og.png The change isn't automatic it can still take Facebook days to weeks to update and show your image.
 

OverHere

Active member
#3
@OverHere to change that logo you will need to change the image located in the styles/xenforo/ directory. The file you need to change with your own logo is logo.og.png. You can specify another name in the ACP I believe but it's easier to just change the file name of the image you want to show there to logo.og.png The change isn't automatic it can still take Facebook days to weeks to update and show your image.
Thank you for this. So, once your instructions are implemented, and whenever FB starts to show up our logo, would this also take effect in the images I attach below, which appear when you sign-up as a new member via FB:

step1.jpg

step2.jpg
 

OverHere

Active member
#5
I believe it takes a bit for Facebook to clear the cache of your logo.og.png.
Yes, but, once the first change in relation to my first message is done by FB (once my dev does the given changes at our end), will our logo also then be reflected in the 2 photos shown in my 2nd message above?

And, for all this, what sized logo should my dev use?

Thank you.
 

Jeremy

Well-known member
#6
Oh, sorry, I misunderstood your last post. I thought you were testing post change, but yes, your logo should appear there as well. As for size, I would just look at logo.og.png and base it off of that.
 

OverHere

Active member
#7
Oh, sorry, I misunderstood your last post. I thought you were testing post change, but yes, your logo should appear there as well. As for size, I would just look at logo.og.png and base it off of that.
xF has a 100 x 100 logo in these 3 FB places... so I think this'll be about the right size?
 

OverHere

Active member
#11
Yeah that particular file is 100x100 so as long as you make it atleast that size you should be fine.
My dev inserted a smaller logo than 100 x 100 and that appeared in all 3 FB areas shown fast. But, when we add the 100 x 100 logo to match that of xF, all 3 boxes stay blank?

How long would it have taken for xF 100 x 100 logo to show up in the 3 areas?

Or, is there something specific that needs to be done to my 100 x 100 logo in respect of making it friendly etc. for logo.og.png?

I just don't want the inserted 100 x 100 logo never to show up, but rather I want t make sure that I am not missing anything in respect of the construction of the 100 x 100 logo which may need doing and after which I can re-insert the logo?
 

OverHere

Active member
#15
Thank you for this. So, once your instructions are implemented, and whenever FB starts to show up our logo, would this also take effect in the images I attach below, which appear when you sign-up as a new member via FB:

View attachment 51141

View attachment 51142
@Brogan Please tell me - the 2 Fb authorisation bits shown in these 2 photos no longer show up on my site at www.satisfy.tv when someone tries to register via FB Login Button. Instead the registering person is taken straight to the site where he is asked to use an existing ID or make a new one?

What needs doing to make sure these 2 authorisation bits always shhow up on my site before the user who is registering is taken to the site to choose a new or existing ID?

Thank you.
 
Last edited:

OverHere

Active member
#17
fb.JPG
Test your Facebook integration:
ACP -> Tools -> Test Facebook Integration
@King Kovifor - thank you. The FB Integration test was good. But, I still do not see the 2 Grey Authorisation pages shown above in this thread. When I try to sign up or log in via the FB Login button, and I successfully enter my FB account details, I am taken straight to this page above.

Would you e kind enough to give a quick check with your own FB account via the FB login button on my siteto see if you can find the 2 misssing Authorisation pages? www.satisfy.tv

Regards.
 

Attachments

Jeremy

Well-known member
#18
You've already authorized the app with your account, it will show to new users. And that is the proper landing page on coming back from a Facebook registration call.

I received the authorization request.
 

OverHere

Active member
#19
thanks for
You've already authorized the app with your account, it will show to new users. And that is the proper landing page on coming back from a Facebook registration call.

I received the authorization request.
thanks for this - so you received both authorisation pages as a new user?