1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Facebook Integration

Discussion in 'XenForo Questions and Support' started by Lionel, Aug 11, 2011.

  1. Lionel

    Lionel Member

    Hi,

    I am finally getting around learning xenForo. I tried the facebook implementation, ran the test successfully in tools, but on the front-end, when I try to login using Facebook, it asked me to accept, blabla, then I got an error

    A controller for the route path /register/facebook was not found.

    What am I doing wrong? Brand new install.
    Thanks.
     
  2. Lionel

    Lionel Member

    OK, answering my own question in case someone else has that issue... I had put a slash '/' in xenforo site name option and that was displaying double slashes.
     
  3. Russ

    Russ Well-Known Member

    Quicker than our own automated Brogan Bot, glad you got it sorted out, and thanks for the answers for others
     
  4. Itworx4me

    Itworx4me Well-Known Member

    Glad to see you finally made it over here Lionel :)
     
  5. Kevin

    Kevin Well-Known Member

    Lionel! Long time no talk.
     
  6. Digital Doctor

    Digital Doctor Well-Known Member

    Really ? Seems like the same problems with settings occur in every software. Can't there be some checker that prevents this problem ? Surely there is an easy solution.
     
  7. Brogan

    Brogan XenForo Moderator Staff Member

    It's explicitly mentioned in the manual: http://xenforo.com/help/facebook/
    Similarly in the ACP -> Options -> Basic Board Information, it states the same for the Board URL.
     
    Nasr likes this.
  8. Lionel

    Lionel Member

    Hi Kevin and Itworx4me. I finally have some time to look at xenForo in depth, and I must say this is really serious stuff.

    Yes Brogan, you are right. But you know, no one really reads those things. I had put a slash in the primary URL of the board. But I easily spotted that by looking at address bar
     
  9. ineedhelp

    ineedhelp Well-Known Member

    Hi...

    I've created a new Facebook account which i want to replace the current Facebook integrated account with on my site.

    But there is no option to edit or change the current Application ID or Secret in the Xenforo control panel.

    Please advise...
     
  10. Brogan

    Brogan XenForo Moderator Staff Member

    There is.

    Options -> Facebook Integration
     
  11. ineedhelp

    ineedhelp Well-Known Member

    Lol.. Thanks!
     

Share This Page