1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Facebook Integration Test Failed

Discussion in 'Troubleshooting and Problems' started by Rho Delta, Aug 3, 2011.

  1. Rho Delta

    Rho Delta Well-Known Member

    { "error": { "type": "OAuthException", "message": "Invalid redirect_uri: Given URL is not allowed by the Application configuration." } }

    I get this error when I run the test. Help?
  2. Brogan

    Brogan XenForo Moderator Staff Member

  3. Kevin

    Kevin Well-Known Member

    In addition to searching out the links that Brogan gave, make sure that your Facebook URL is correct. Yesterday I ran into the same error you are and in my case the answer was because when I created the Facebook app I used "http://www.mysite.com" as the URL but I then added a .htaccess to my site to redirect www.mysite.com to just mysite.com without the www in front. After updating the FB app settings to also not have the www as part of the domain then it worked for me. It was actually throwing me off for a bit because I set up 3 nearly identical XF installs and 2 were working fine but not the 3rd.

    The URL in question that solved for me was the FB apps page (https://www.facebook.com/developers/apps.php) then clicking on the app name then "Edit Settings" then "Web Site" and then the "Site URL" value.

    Might not be issue but be sure to check the "Site URL" value to make sure it is the valid full URL to your site.
  4. Rho Delta

    Rho Delta Well-Known Member

    Fixed! Thanks, works great!

Share This Page