• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Facebook Integration stopped working...any ideas?

#1
Hello folks!

For some reason, my Facebook sign-in integration was working fine, but has since stopped working and I'm not quite sure what the problem is.

It connects to Facebook when you click "Login with Facebook", it asks you to skip or allow posts to your Facebook account, then it redirects you back to my site with a "Page could not be found" error.

Could somebody take a peek at my forum: http://www.photographybb.com/community and see if they know what might be wrong?

Thank you very much for your help in advance!

Dave
 
#4
I'm not a facebooker so I can't test it. But you should check the steps listed here:

http://xenforo.com/help/facebook/
Hi Jake, thanks for the reply. Unfortunately the info page that you've referenced is not quite up to date with Facebook's new app creation schema. However, that doesn't matter too much, because I've found the problem - I just don't know how to fix it!

Using my URL as an example (xenForo is installed in the the directory named "community")... The problem is that the login redirect shows up in the URL bar as: http://www.photographybb.com/community/index.php?register%252Ffacebook&code=AQACC4GNV.....

If I manually replace the %252F with a slash / then the Facebook integration works. Any idea how to prevent that from happening?

Thanks in advance for your outstanding support man :)
 

Jake Bunce

XenForo moderator
Staff member
#5
I don't see where that location is coming from. Is XF redirecting you there or is Facebook?

Like I said, I don't use Facebook so I am unfamiliar.
 
#6
Facebook is redirecting there. In the integration setup, it says to include you forum's root directory followed by the "/". I've tried with and without and the %252F continues to cause the problem on the redirected URL.

%252D is the URL encoding for a slash, but that's what's causing the problem in the integration.

Thanks for taking a look at this thread either way. I appreciate it :)