XF 1.5 Facebook api login error

JK2447

Member
Hi all. I was told I need to update the Facebook api settings on my forum 1.5.18 (I bought it from a nice chap who created it long ago). I’ve followed the instructions which were easy enough. Created the app on the Facebook developer site. Put my app id and secret into my admin page but now I keep getting the following error. My forum is https using Cloudflare if that makes a difference. Any help would be much appreciated

Insecure Login Blocked: You can't get an access token or log in to this app from an insecure page. Try re-loading the page as https://
 

Chris D

XenForo developer
Staff member
The redirect URI which is generated for use in the request to Facebook seems to be using http://

The most likely cause for that is your boardUrl value not yet having been updated to be https:// rather than http://
 

JK2447

Member
Hi Chris. Am I right in saying I need to make this change in the admin page, options, basic board information? I changed http to https but this hasn’t fixed my issue sadly
 

Chris D

XenForo developer
Staff member
Well, it's changed the issue.

The error is different now:
Can't load URL: The domain of this URL isn't included in the app's domains. To be able to load this URL, add all domains and sub-domains of your app to the App Domains field in your app settings.
You'll need to change your Facebook app settings so that your domain is listed under "App Domains".
 

JK2447

Member
Thanks Chris. My error has now changed again. I’m not very good at this

Can't load URL: The domain of this URL isn't included in the app's domains. To be able to load this URL, add all domains and sub-domains of your app to the App Domains field in your app settings.
 

JK2447

Member
Sorry Chris you are right. I did read your advice of course but thought the error was slightly different. I’ve added my sites domain but no luck.
 

Attachments

  • 0B9F517A-0F1C-4E25-B472-602E72465ED7.png
    0B9F517A-0F1C-4E25-B472-602E72465ED7.png
    237.9 KB · Views: 23

JK2447

Member
Thanks Chris. Unfortunately when I test that URI it says

QpYjQP4uuh9.png

This is an invalid redirect URI for this application
You can make this URI valid by adding it to the list of valid OAuth redirect URIs above
 

JK2447

Member
I figured I'd try to re-create the app in facebook to see what would happen. I now get this error. I'm sure when I had this first I added my sites IP address to the white list, this could be incorrect

URL blocked: This redirect failed because the redirect URI is not white-listed in the app's client OAuth settings. Make sure that the client and web OAuth logins are on and add all your app domains as valid OAuth redirect URIs.
 

JK2447

Member
HI Chris, sorry to ask about this again I really am. I've started again, followed the instructions, and I get

Can't load URL: The domain of this URL isn't included in the app's domains. To be able to load this URL, add all domains and sub-domains of your app to the App Domains field in your app settings.

In this field in Settings>Basic>App Domains I have certforums.com
I thought this would be correct would you?
 
Top