Fixed FA code missing for "brands" icon set support

Affected version
2.0, 2.1

Iggy

Active member
this is regarding the editor specifically when i tried to assign some FA icons to BBcode buttons....the "brands" set would not work for me....perhaps as i am not a "pro" customer? i saw this on xen 2.0 and 2.1 both...
there is a secondary issue as well......which is in the admincp templates somewhere but i did not trace that one...in the toolbar editor page...

i discovered it in this discussion where u can see more details to the code fix i implemented...

 

XF Bug Bot

XenForo bug fixer bot
Staff member
Thank you for reporting this issue. It has now been resolved and we are aiming to include it in a future XF release (2.1.1).

Change log:
Support editor icons in specific FA packs by specifying the icon as "fa(l|r|s|b) fa-icon-name".
Any changes made as a result of this issue being resolved may not be rolled out here until later.
 

Matthew S

Active member
Change log:
Support editor icons in specific FA packs by specifying the icon as "fa(l|r|s|b) fa-icon-name".
Specifying the font pack already works, including for brands. The default "fa" was deprecated in the change to FA5. The "fa" still works (I haven't tested extensively, but it seems to default to the solid set), however you cannot access the brands set that way (so brands icons broke from XF2.0 -> 2.1). I'm not quite sure what is being fixed? Is it just the manual getting updated?

Edit: I meant to add, will we be able to specify brands icons using code like below in extra.less?
Code:
.node--id5 .node-icon i::before {
content: "\f072" !important;
}
What would be nice is an update past FA5.6. :)
 
Last edited:

Mike

XenForo developer
Staff member
We use roughly the "standard" FA5 approaches. If you want to use a brand icon or a particular variant type, you need to either apply the correct class (fab, far, and so on) or select the correct font (if you're doing the CSS approach). This isn't something we're changing.

This issue was specifically about custom editor icons (via custom BB codes) not supporting requests for specific variants of a FA icon, including brand icons. To do that, you'd use the naming as specified by the FA docs. For example, consider this Facebook icon; you'd use fab fa-facebook-f as the FA icon definition in for the editor icon to access it.
 
Top