• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 every user has same ip?

#3
Do you have some kind of reverse proxy set up?
How do i check this? Sorry if i act like a noob i dont have the software so long yet.

Edit: i do have this in my config.php
// FIX IP ADDRESS FOR PROXY
$_SERVER['REMOTE_ADDR'] = $_SERVER['SERVER_ADDR'];
$_SERVER['HTTPS'] = 'on';
 
#7
I have no idea what use that would have to force https:

I would take that out. It sounds exactly like the issue you're having
i dont know why i added it i thought it was because it fixed some other issue i removed it and everything loads fine no issues so far so will see how it goes
 

SneakyDave

Well-known member
#8
If you're not using a reverse proxy, and you would probably know if you were (lol),you wouldn't need that. I'm not even sure what setup would require that.
 

Kirby

Well-known member
#9
PHP:
$_SERVER['REMOTE_ADDR'] = $_SERVER['SERVER_ADDR'];
This is complete nonsense :)

Setting
PHP:
$_SERVER['HTTPS'] = 'on';
is normally only necessary if the webserver is behind a proxy which does terminate TLS.

In this case, the original IP address is usually forwarded to the backend server as an additional HTTP Request Header.
This could be either X-Forwarded-For, RFC 7239 compliant Forwarded or any other Non-Standard-Header.
You'll have to find out which header is being used and (ideally) configure your webserver acordingly (eg. by using mod_rpaf/mod_remoteip for Apache, ngx_http_realip_module for nginx).