1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Errors using Amazon SES for sending Mail (SMTP)

Discussion in 'Troubleshooting and Problems' started by Robust, May 12, 2015.

  1. Robust

    Robust Well-Known Member

    Problems using amazon SES.

    So I created SMTP creds on Amazon SES. Which redirects me to: https://console.aws.amazon.com/iam/home?#s=SESHome

    There I created something, got the username and pass. After that I setup the domain in SES, set up DKIM and enabled it, domain is verified.

    So the user's policy on AWS is the default but I added a star notation (*) to give it all SES permissions:

    Code:
    {
        "Version": "2012-10-17",
        "Statement": [
            {
                "Effect": "Allow",
                "Action": "ses:*",
                "Resource": "*"
            }
        ]
    }
    So the initial issue I had was:
    Email to webmaster@robust.cat failed: Message rejected: Email address is not verified.

    That's when I changed Action to ses:*. After that it didn't give that error for the email address webmaster@robust.cat. Emails are being sent by gamingforums.net, so the domain robust.cat isn't recognised or known by SES at all.

    [​IMG]

    As you can see, all SES permissions are allowed (I threw in a CloudFront just to check). This is on stimulate policies.

    So I'm using the info, and I no longer get the cannot verify email error for my email, I don't get any error at all but the email doesn't send (I don't get the email).

    For some other members (their email worked with Mandrill previously) they get logged in Server Errors with the email validate thing:
    Code:
    Zend_Mail_Protocol_Exception: Email to someuser@att.net failed: Message rejected: Email address is not verified. - library/Zend/Mail/Protocol/Abstract.php:431
    Generated By: Unknown Account, Today at 11:20 AM
    Stack Trace
    #0 /library/Zend/Mail/Protocol/Smtp.php(324): Zend_Mail_Protocol_Abstract->_expect(250, 600)
    #1 /library/Zend/Mail/Transport/Smtp.php(215): Zend_Mail_Protocol_Smtp->data('Subject: Hostag...')
    #2 /library/Zend/Mail/Transport/Abstract.php(348): Zend_Mail_Transport_Smtp->_sendMail()
    #3 /library/Zend/Mail.php(1194): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
    #4 /library/XenForo/Model/MailQueue.php(79): Zend_Mail->send(Object(Zend_Mail_Transport_Smtp))
    #5 /library/XenForo/Deferred/MailQueue.php(10): XenForo_Model_MailQueue->runMailQueue(7.9999990463257)
    #6 /library/XenForo/Model/Deferred.php(294): XenForo_Deferred_MailQueue->execute(Array, Array, 7.9999990463257, '')
    #7 /library/XenForo/Model/Deferred.php(428): XenForo_Model_Deferred->runDeferred(Array, 7.9999990463257, '', false)
    #8 /library/XenForo/Model/Deferred.php(373): XenForo_Model_Deferred->_runInternal(Array, NULL, '', false)
    #9 /deferred.php(23): XenForo_Model_Deferred->run(false)
    #10 {main}
    Request State
    array(3) {
      ["url"] => string(41) "https://www.gamingforums.net/deferred.php"
      ["_GET"] => array(0) {
      }
      ["_POST"] => array(4) {
        ["_xfRequestUri"] => string(32) "/threads/hostage-situation.3396/"
        ["_xfNoRedirect"] => string(1) "1"
        ["_xfToken"] => string(8) "*"
        ["_xfResponseType"] => string(4) "json"
      }
    }
    
    What am I doing wrong?
     
  2. Robust

    Robust Well-Known Member

    Well, my server can connect fine:

    http://paste.ubuntu.com/11101457/

    [root@gamingforums ~]# telnet email-smtp.us-west-2.amazonaws.com 587
    Trying 54.149.142.243...
    Connected to email-smtp.us-west-2.amazonaws.com.
    Escape character is '^]'.
    220 email-smtp.amazonaws.com ESMTP SimpleEmailService-data data
     
  3. Robust

    Robust Well-Known Member

    Fixed. There's a status update on my profile page if anyone has the same problem and my resolution.
     
  4. Kintaro

    Kintaro Well-Known Member

    1. Robust Fixed it, it was bounce email. Apparently it doesn't like Gmail to bounce?

    2. Robust Added email as verified email address, if anyone has the same problem again, check your bounce settings. Amazon SNS is probably going to be cheaper for bounced emails.
    added your profile messages here so it easier for people to know the solution
     

Share This Page