• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 ErrorException: Undefined index: sigPerms

Brent W

Well-known member
#1
Code:
Error Info
ErrorException: Undefined index: sigPerms - library/XenForo/ViewPublic/Account/Signature.php:10
Generated By: Rubynelson, Today at 10:05 AM
Stack Trace
#0 /home/girls/public_html/library/XenForo/ViewPublic/Account/Signature.php(10): XenForo_Application::handlePhpError(8, 'Undefined index...', '/home/girls/pub...', 10, Array)
#1 /home/girls/public_html/library/XenForo/ViewRenderer/Abstract.php(220): XenForo_ViewPublic_Account_Signature->renderHtml()
#2 /home/girls/public_html/library/XenForo/ViewRenderer/HtmlPublic.php(67): XenForo_ViewRenderer_Abstract->renderViewObject('XenForo_ViewPub...', 'Html', Array, 'shs_can_not_mod...')
#3 /home/girls/public_html/library/XenForo/ViewRenderer/Abstract.php(242): XenForo_ViewRenderer_HtmlPublic->renderView('XenForo_ViewPub...', Array, 'shs_can_not_mod...', NULL)
#4 /home/girls/public_html/library/XenForo/ViewRenderer/HtmlPublic.php(64): XenForo_ViewRenderer_Abstract->renderSubView(Object(XenForo_ControllerResponse_View))
#5 /home/girls/public_html/library/XenForo/FrontController.php(569): XenForo_ViewRenderer_HtmlPublic->renderView('XenForo_ViewPub...', Array, 'account_wrapper', Object(XenForo_ControllerResponse_View))
#6 /home/girls/public_html/library/XenForo/FrontController.php(156): XenForo_FrontController->renderView(Object(XenForo_ControllerResponse_View), Object(XenForo_ViewRenderer_HtmlPublic), Array)
#7 /home/girls/public_html/index.php(13): XenForo_FrontController->run()
#8 {main}
Request State
array(3) {
  ["url"] => string(43) "http://www.girlsforum.com/account/signature"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(0) {
  }
}
 

Chris D

XenForo developer
Staff member
#2
Can you reproduce this consistently? Simply on page load? Or do you have to do something to trigger it? Fresh XF 1.2 install or upgrade from 1.1? Any add-ons installed relating to signature permissions?
 

Chris D

XenForo developer
Staff member
#4
Just checked the code. The only way I can see this happening is if not all files have been uploaded correctly, or there's an add-on you already have that extends the account controller and the signature action incorrectly.

First step: Run a file health check.

If that all checks out: Disable all add-ons and try again.
 

Chris D

XenForo developer
Staff member
#7
Maybe disable Stop Human spam, I've heard issues with Tapatalk...

Failing those two, disable the whole lot.
 

Mike

XenForo developer
Staff member
#8
Well, there's one that specifically deals with signatures there, so that might be the first thing to check. But I could really only recommending disabling all listeners ($config['enableListeners'] = false; in config.php) and seeing if the errors still come in.