1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

error_log file?

Discussion in 'Troubleshooting and Problems' started by kuyenmotdivad, Oct 21, 2010.

  1. kuyenmotdivad

    kuyenmotdivad Active Member


    I keep getting this error_log file generated with this error inside it, any idea whats wrong?

    [21-Oct-2010 15:20:17] PHP Warning:  PHP Startup: apc.shm_size now uses M/G suffixes, please update your ini files in Unknown on line 0
  2. Lawrence

    Lawrence Well-Known Member

    Moved to General Troubleshooting as it looks to be an APC config issue.
  3. Floris

    Floris Guest

    This is what I use in my xenforo v1 config.php (below everything else)

    $config['cache']['frontend'] = 'Core';
    $config['cache']['frontendOptions'] = array(
    'caching'                      => true,
    'automatic_serialization'      => true,
    'lifetime'                      => 10800,
    'cache_id_prefix' => 'fans'
    $config['cache']['backend'] = 'Apc';
    Note how the cache_id_prefix is set to fans.

    To learn more about using / enabling APC for XenForo, see this documentation:

    # http://xenforo.com/community/threads/speed-up-your-board-caching.5699/
    # http://xenforo.com/community/threads/tip-use-apc.6456/
    Jake Bunce likes this.
  4. kuyenmotdivad

    kuyenmotdivad Active Member

    Added this to my config file but its still showing that error.
  5. g0rn

    g0rn Well-Known Member

    What do you have in your php.ini file set to that option (apc.shm_size)? It should be something like 256M, not just 256.
    DaveTomneyUK and Floris like this.
  6. kuyenmotdivad

    kuyenmotdivad Active Member

    will have a look thanks when I can work out how to edit and save it in SSH.... i'm a noob with SSH.

    Could you tell me step by step in how to load and edit and save php.ini please?
  7. Floris

    Floris Guest

    locate php.ini
    then you have it.

    cat /path/to/php.ini |grep "apc.shm_size"

    and it should spit out the line disclosing 256 or 256M
  8. Floris

    Floris Guest

    root@mrfloris:~# cat /etc/php5/apache2/php.ini |grep "apc.shm_size"
    #apc.shm_size = 128
    root@mrfloris:~# locate apc.ini
    root@mrfloris:~# cat /etc/php5/conf.d/apc.ini |grep "apc.shm_size"

    That's all I could think of.

    The # in front of the line means it's commented out, so it's not actually set to 128 for my system. So it goes to 'default'; whichever that is.

    Make a new file called phpinfo.php with content <?=phpinfo(); and run it from the browser.
    Search for APC, maybe it will disclose more details. And if not, then type

    locate apc.php
    cp /path/to/apc.php $HOME/public_html/apc.php

    and run apc.php from the browser.
  9. Blandt

    Blandt Well-Known Member

    Did you manage ok ?
  10. kuyenmotdivad

    kuyenmotdivad Active Member

    No i'm strugling I cant find which php file to edit... theres about 10 php.ini files in different locations

    also if I load a file using

    vi php.ini then click [escape] and type in :wq is wont have messed up the php.ini file will it or when you recompile does it rewrite all the php.ini files?
    Blandt likes this.
  11. Blandt

    Blandt Well-Known Member

    according to the info i had from yesterday this is the one :

  12. Blandt

    Blandt Well-Known Member

    After you edit the php.ini you need to reload Apache by running this :
    sudo /usr/sbin/apachectl graceful
  13. kuyenmotdivad

    kuyenmotdivad Active Member

    All working perfect now, Thanks

Share This Page