1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Error with installing.

Discussion in 'XenForo Questions and Support' started by ashkir, Oct 23, 2012.

  1. ashkir

    ashkir Active Member

    Hi there! I tried to uninstall an addon to reinstall it, I'm getting an error. The addon works correctly it seems, but, I cannot uninstall it as it doesn't show in my addon list.


    I tried navigating to it manually it says it doesn't exist. I was upgrading the versions when this came up. :/ Decided to completely uninstall and reinstall. Anyone know how to fix this?

    Server Error

    Mysqli statement execute error : Table 'xf_cz_group' already exists
    1. Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
    2. Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
    3. Zend_Db_Adapter_Abstract->query() in XfAddOns/Groups/Install/Install.php at line 98
    4. XfAddOns_Groups_Install_Install::step1() in XfAddOns/Groups/Install/Install.php at line 14
    5. XfAddOns_Groups_Install_Install::install()
    6. call_user_func() in XenForo/Model/AddOn.php at line 214
    7. XenForo_Model_AddOn->installAddOnXml() in XenForo/Model/AddOn.php at line 169
    8. XenForo_Model_AddOn->installAddOnXmlFromFile() in XenForo/ControllerAdmin/AddOn.php at line 178
    9. XenForo_ControllerAdmin_AddOn->actionInstall() in XenForo/FrontController.php at line 310
    10. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
    11. XenForo_FrontController->run() in /home/rpgdir/public_html/admin.php at line 13
  2. Adam Howard

    Adam Howard Well-Known Member

    Jake Bunce likes this.
  3. xfrocks

    xfrocks Well-Known Member

    There are 2 problems
    1. The add-on uninstall script doesn't drop the database table
    2. The install script doesn't check for the table's existence before issuing CREATE TABLE query
    There are 2 ways to fix this
    1. Go to your MySQL management tool, drop that table. You may want to check if the add-on creates any other tables and drop them all as well
    2. Modify the install script, replace CREATE TABLE with CREATE TABLE IF NOT EXISTS
    Jake Bunce likes this.
  4. ashkir

    ashkir Active Member

    The developer sent me a sql query fix. :)
    Adam Howard and Andrej like this.

Share This Page