1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Error when trying to import

Discussion in 'Installation, Upgrade, and Import Support' started by Moshe1010, Jul 31, 2013.

  1. Moshe1010

    Moshe1010 Well-Known Member

    I'm trying to import from vB4 to 1.2 with the home importer and I get this:

    mb_convert_encoding(): Illegal character encoding specified

    Any idea what can cause this? my vB 4 SQL currently works as Windows 1255.
    I tried to force it to Windows 1255, UTF-8, and latin1, but it's still doesn't want to import anything.

    I've tried to import wit the vB4 add-on importer and it worked fine without forcing any encoding, so I'm not really sure why the home importer doesn't work.
    Last edited: Jul 31, 2013
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    I saw Mike say this is a bug that will be fixed. In the meantime one option is to import into XF 1.1 then upgrade to 1.2.
  3. Moshe1010

    Moshe1010 Well-Known Member

    Thanks. Would I be able to use your importer for 1.2?
    vB4 Importer 3.6b2

    Edit: it's not. I guess I would need to go the 1.1.5-->1.2 route. Thanks.
    Last edited: Jul 31, 2013
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Probably maybe. I do not know if the bug affects the unofficial vB4 importer.
  5. Moshe1010

    Moshe1010 Well-Known Member

    It is.
  6. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

  7. 0ptima

    0ptima Well-Known Member

    BTW, xf 1.1 does not have post edit history. but 1.2 does and it gets imported.

Share This Page