1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Error when setting up a second Feed

Discussion in 'Troubleshooting and Problems' started by Wasserlasser, Sep 13, 2015.

  1. Wasserlasser

    Wasserlasser Active Member

    Hi,

    I am trying to set up a second feed (first one works perfect) and I get this error

    Could not determine temp directory, please specify a cache_dir manually
    1. Zend_Cache::throwException() in Zend/Cache/Backend.php at line 197
    2. Zend_Cache_Backend->getTmpDir() in Zend/Cache/Backend/File.php at line 123
    3. Zend_Cache_Backend_File->__construct() in Zend/Cache.php at line 153
    4. Zend_Cache::_makeBackend() in Zend/Cache.php at line 94
    5. Zend_Cache::factory() in Zend/Locale/Data.php at line 943
    6. Zend_Locale_Data::getContent() in Zend/Locale/Format.php at line 1092
    7. Zend_Locale_Format::getDateFormat() in Zend/Locale/Format.php at line 1119
    8. Zend_Locale_Format::getDate() in Zend/Date.php at line 2149
    9. Zend_Date->_calculate() in Zend/Date.php at line 1078
    10. Zend_Date->set() in Zend/Feed/Reader/Feed/Rss.php at line 238
    11. Zend_Feed_Reader_Feed_Rss->getDateModified() in XenForo/Model/Feed.php at line 187
    12. XenForo_Model_Feed->getFeedData() in XenForo/DataWriter/Feed.php at line 95
    13. XenForo_DataWriter_Feed->_preSave() in XenForo/DataWriter.php at line 1446
    14. XenForo_DataWriter->preSave() in XenForo/DataWriter.php at line 1385
    15. XenForo_DataWriter->save() in XenForo/ControllerAdmin/Feed.php at line 127
    16. XenForo_ControllerAdmin_Feed->actionSave() in XenForo/FrontController.php at line 347
    17. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    18. XenForo_FrontController->run() in /www/htdocs/w00e34a8/admin.php at line 13
    Any idea what this means?
     
  2. Mike

    Mike XenForo Developer Staff Member

    What's the feed URL?

    However, this error isn't 100% related. It's related to your server/PHP configuration. The most direct thing would be to explicitly set a upload_tmp_dir setting in your php.ini file (that PHP can use). (Do uploads/attachments actually work?)
     
  3. Wasserlasser

    Wasserlasser Active Member

    Hi Mike,

    it looks like it was a problem with the Feed. I was able to set up other Feeds with no problem at all.

    Wasserlasser
     

Share This Page