1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Error when disabling add-ons

Discussion in 'Installation, Upgrade, and Import Support' started by Paul, Aug 2, 2013.

  1. Paul

    Paul Well-Known Member

    Strangely, have disabled some add-ons, however the rest don't seem to want to disable....

    e.g. when trying to disable TMS....

    EDIT : Also getting this....
    Fatal error: Maximum execution time of 60 seconds exceeded in /community/library/XenForo/Template/Compiler.php on line 549

    Anyone any clues or ideas I can try?? This now happens on everything I try to disable... :(

    Last edited: Aug 2, 2013
  2. Martok

    Martok Well-Known Member

    Did you disable it before or after upgrading?

    If after, have you tried this and then tried disabling TMS?

  3. Paul

    Paul Well-Known Member

    Before :)

    Am onto my host now, since i'm getting timeouts, and didnt on the first few i disabled. Suspect it may be an issue with them... :( Typical timing!!
  4. Mike

    Mike XenForo Developer Staff Member

    So the lock timeout is probably related to the PHP timeout.

    I'm slightly unclear. Is this happening on 1.1 or 1.2? (Before or after the upgrade?)

    There are a few possibilities, but there may actually be interference from TMS when trying to disable it. You should do the enableListeners = false thing in config.php then try to disable it.
  5. Paul

    Paul Well-Known Member

    Hiya Mike,

    It's on 1.1.5 before i've taken any steps to upgrade (First step being to disable all addons) :)

    However, saying that, $config['enableListeners'] = false; and then trying again to disable seems to have worked fine!!

    What would cause this?? (Thanks for the heads up!)

  6. Mike

    Mike XenForo Developer Staff Member

    One of the add-ons interfered with the disable process. I'm guessing TMS as it would trigger template rebuilds that wouldn't normally happen.

    If you're upgrading to 1.2 you don't have to do anything else, but if you're not, then you may still see template modifications on your board - rebuilding the master data via /install/ should sort that.
    Last edited: Aug 2, 2013
    Paul likes this.
  7. Paul

    Paul Well-Known Member

    Many thanks for your help Mike :)
  8. Paul

    Paul Well-Known Member

    Just a quickie - In server error log getting :

    Zend_Db_Statement_Mysqli_Exception: Mysqli prepare error: Table 'forum.xf_deferred' doesn't exist - library/Zend/Db/Statement/Mysqli.php:77

    Anything to worry about??
  9. Mike

    Mike XenForo Developer Staff Member

    Provided it doesn't keep happening, no. It's a race condition during the upgrade upload process.

Share This Page