Error uploading attachments

duderuud

Well-known member
I think I remember seeing an issue here and there (mainly add-ons) that had 8.1 issues... it's why I don't recommend it. The current is the 8.0.xx line that is the highest recommended.
It's true 8.1 isn't officially supported. But FYI, I am running 8.1 for months now on a big board without any issues.
 

Tracy Perry

Well-known member
It's true 8.1 isn't officially supported. But FYI, I am running 8.1 for months now on a big board without any issues.
And some people swallow swords that are on fire. ;)
Pushing the envelope is rarely suggested if a site is targeted at always being available. It's more an indicator of the admin's desire to be "on the cutting edge" instead of being firmly on the base of "reliability". Typically when the crap hits the fan and the site quits working because they were on that edge and they are now bleeding to death, they are the ones that yell the loudest. 🤷‍♂️
 

Tracy Perry

Well-known member
Not looking to be on the cutting edge,
Sorry to burst your bubble.. but if you are running a non-supported version of PHP on a script... you ARE on the cutting edge. It's apparent that stability is one of your lesser concerns. There is NO getting around that.
 

duderuud

Well-known member
Call it what you want. I did extensive testing and found no issues so upgraded the live site to 8.1 and again, no issues at all.

To each their own.

BTW:
E7B2E597-FE7F-4690-983C-E9CB32B545AE.png
Xenforo supports 8.1, they just don't recommend it yet.
 

Tracy Perry

Well-known member
Xenforo supports 8.1, they just don't recommend it yet.
Really... is that why certain developers and support have been VERY concise that 8.1 was not a supported version under the 2.2.1x script?
There are a WEALTH of posts here that are directly related to 8.1 and issues it has with the current version of XF... and MANY of them posted in the bug fix area.
Like I said, last I looked, XF developers did NOT recommend you run 8.1 as it was "cutting edge" and the current version of XF was not "certified" for PHP 8.1 compatibility... but you do you and enjoy living on that cutting edge. Will it run.. yep... will it have issues that will crop up, yep, as proven by the bug fix entries.
Realize.. we aren't talking the "cutting edge" of PHP having been out a while.. but the cutting edge of the fact that it has not been reliably & extensively TESTED against the current versions of the script. That's generally referred to either ALPHA or BETA testing.. and has not been (at least since my OS/2 2.1 days) been recommended as a position of stability - and I BETA'd MANY an OS/2 app related to FidoNet back then (actually ran 2.0 for a while until 2.1 came out, and prior to that DESQview for a multi-node BBS).
 
Last edited:

DaveL

Well-known member
In your ACP change from ImageMagic to GD for image processing.

ACP -> Attachments -> Default Image Processor.
Thanks, just had a look and it's already set to GD.
The main issue seems to be large zip files via the Resource Manager.
 

DaveL

Well-known member
I've turned off FastCGI and it's allowing me to upload again. Whether it will work for the people that had the same issue before, who knows!
Am I losing much by having FastCGI turned off?
Would it be worth considering using nginx instead of apache?
I only have two sites - One is just a general forum, the second is where people upload large files.
 
Last edited:

DaveL

Well-known member
One more question!
Is it worth having apache keep-alive switched on? If so, is the default 15 seconds suffice?
I have had a read up on it, however didn't know whether it would cause issues when uploading large files.
 
Top