1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Error upgrading via CLI

Discussion in 'Installation, Upgrade, and Import Support' started by hungphutho, Aug 4, 2013.

  1. hungphutho

    hungphutho Member

    @Brogan @Jake Bunce please help me , I use CLI upgrader to upgrade 1.1.5 to 1.2
    Ussing
    php library/XenForo/Install/run-upgrade.php
    Error
    screenshots
    Capture10.PNG
    My forum 6 million posts and Members 100K .
     
  2. hungphutho

    hungphutho Member

    I have resolved
    My temporary solution venture :)
    Detele file 1020032-120b2.php in foder library/XenForo/Install/Upgrade , and open browser to http://myforum/install/index.php?upgrade/ success from 1020034-120b4.php used to finalize :)
     
  3. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Strange.

    Step 14 is the final step in that file and it finished so there should be no harm deleting it. Though I'm not sure why that would be necessary.
     
  4. Mike

    Mike XenForo Developer Staff Member

    That actually implies that an exception occurred but it was masked because of that.

    Unfortunately, if the issue has been resolved, we won't be able to do any debugging.
     
  5. hungphutho

    hungphutho Member

    I think this error is the cause of my server.
    This is a screen capture
    Before I open the browser to perform complete step 1.2 BETA 4
    Capture11.PNG
    In summary. My problem is encountered CLI does not perform the next step installation
    Maybe this is the exception :)
    sorry my english poor
     
  6. Mike

    Mike XenForo Developer Staff Member

    Can you make this change in library/XenForo/Error.php? (Red is the old version, green is the new version.)

    upload_2013-8-5_15-24-13.png

    Try the CLI upgrader again. Hopefully we will get an actual error message then.
     

Share This Page