• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 Error (possibly fav icon)

#1
For some reasons there are a few users that are getting the following error:

Template Errors: PAGE_CONTAINER

  1. htmlspecialchars() expects parameter 1 to be string, array given in /home/dreamreef/domains/dreamreef.nl/public_html/library/XenForo/Template/Helper/Core.php, line 2049:
2. 2048: unset($__compilerVar74);

3. 2049: $__output .= '

4. 2050: <LINK REL="SHORTCUT ICON" HREF="http://dreamreef.nl/styles/favicon.ico">

Can anyone tell me what I can do to get rid of this? Because for some reason I cannot recreate the error on my own system.

Cheers,

Maarten
 

Brogan

XenForo moderator
Staff member
#2
You shouldn't be running in debug mode on a production site for a start.
I notice also there are 82 queries on the forum index page - that is massively high.

Has the PAGE_CONTAINER template been modified?

Do the errors occur with add-ons disabled and in a default style?
 
#3
The Page_Container has been modified to add the favicon.ico Other then that no it has not been modified. I turned off the debug mode, thnx! I will try and go through add ons to see if it helps.
 

Brogan

XenForo moderator
Staff member
#4
You can revert the template.

All you need to do is add the favicon to the root.

I suspect though that the problems are add-on related.
 

Mike

XenForo developer
Staff member
#5
There may be a bug from a previous version that you're just seeing now since you're in debug mode. Rebuilding the user cache should sort it.