• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 Error on uploading attachments

DaveM

Well-known member
#1
I have a photography forum and my members are getting this error when uploading photos as attachments. My attachment settings are as follows.

Maximum Attachment File Size (KB) 1024
Maximum Attachment Image Dimensions 1920 x 1200
Default Image Processor ImageMagick PECL Extension

upload_2014-9-26_11-7-34.png

It would seem if they go back and resize the image it will work. However this is an issue as we are loosing a few uploads as members. It seems they do not want to be worried about having to do this each time they want to upload a photo to the forum.
 

Brogan

XenForo moderator
Staff member
#4
You may need to increase some of the server limits, specifically php_value upload_max_filesize and php_value post_max_size.
 

DaveM

Well-known member
#5
Is there no way to have the file resized to fit the forum configuration. The problem is with a photography forum these photo tend to mostly be high resolution photos. So you also cannot really go to large due to the amount of imaged that will be uploaded and then using up all your resources.
 

MattW

Well-known member
#6
Is there no way to have the file resized to fit the forum configuration. The problem is with a photography web forum these photo tend to mostly be high resolution photos. So you also cannot really go to large due to the amount of imaged that will be uploaded and then using up all your resources.
It will be resized, but your PHP settings need to be set to allow it to be uploaded and processed.
 

AndyB

Well-known member
#11
There is a little know setting that is needed to be put into the config.php file which will correct the problem you are experiencing.

$config['maxImageResizePixelCount'] = 30000000;

This link explain what this setting does. Notice how I increased this value in order to keep up with the ever increasing images sizes taken with modern cameras.

https://xenforo.com/help/config-php-options/